Opera v.11.xx M2 - some mails not showing in labels

  • Helloe all,

    I noticed my labels ( some call folders ) is most of the time not properly showing all the mails filtered by the rules.

    The more I notice that is, I could be able to make those ' no show ' emails coming back on in that label by doing this:

    1. Right click the specific labels.

    2. Choose Properties.

    3. and then close.

    Then I can see some emails start jumping in & re-appear again in that labels.

    My question is, is there a shortcut thing I can do the above 1. , 2. & 3 ? ===> to all labels at same time ?

    ( so that I do not have to repeat each action 1., 2. & 3. on each labels )

    Problem is that, I am currently working with 60+ labels in a session ( everyday ) and I think the time I spent would be enormous if I am to do 1. , 2. & 3. few times a day in order to make sure I see all email sin each labels.

    Thank you !

    Edmond.

  • and............... I know the reason to why mails not properly showing in each labels because.........

    I alter the index.ini and the sessions ( opera.win ) between office machine & home machine.

    When at night, I email index & opera.win to my gmail. ( for my next day in office )

    When at day, I download from gmail the above 2 files, save to my office machine.

    So that in office I have the same session just like I did last night from home.

    Thank you

  • The more I notice that is, I could be able to make those ' no show ' emails coming back on in that label by doing this:

    That's probably causing the rules to re-evaluate, which is why it fixes it.

    My question is, is there a shortcut thing I can do the above 1. , 2. & 3

    Edit properties & delay, 1000 & Close window & delay, 1000 & Next item
    

    (Repeat those as many times as needed in your command and adjust the delays as low as you can get them where things still work.)

    First left-click the first label under the "Labels" access point. Then, click that label again to truly select it. Then invoke the shortcut.

    and............... I know the reason to why mails not properly showing in each labels because

    OK

  • Btw, define that under the "Mail Panel" section in shortcuts.

    Also, the way I discovered those commands:

    • I looked in standard_menu.ini to see what command was used for the "properties" item in the right-click context menu for a label. It was "edit properties". So, I tested that and it didn't work. I clicked the label again and tried the shortcut again and it worked.

    • I then typed "close" in the shortcut action field to get the list of commands to show up that started with "close". I first tried "close widget". When that didn't work, I tried" "Close Window", which didn't work either. But, I then tried a delay with close window and it worked.

    • I then typed "focus" in the action field to bring up commands that started with "focus". I tried a few of those like "focus next widget" etc. and none of those worked. So, I typed just "next" and find "next item" (which sounded more of what I wanted) , which didn't work until I tried a delay. Then it worked fine.

    That's basically how to figure stuff like this out if you don't know it.

    1. Right click the specific labels.
    2. Choose Properties.
    3. and then close.

    Note that Opera often optimizes out the applying of a preference when a setting hasn't changed. If that ends up being the case for you (although it should be as the steps work you said), you might have to add some commands to change something in the dialog and then change it back to get the rules to re-evaluate. Again, doesn't seem like you'll need to do that in this case, but with some things it is the case.

  • Thanks burnout426,

    works perfectly !

    1. However, from the 1st launch of your command, it does not focus to the properties pop-up dialogue box., properties dialogue box pops-up, but is dim. I have to manually click on the top of the box to make it focus, then your command continue doing it's job to open labels one by one.

    If I sit there do nothing nor to click the dialogue box, the dialogue box ( dimmed ) just sit there without doing anything also.

    Is there a small setting I could make it Auto Focus to the properties dialogue box from it's 1st launch ?

    1. If I am to use your command instead of assign to the keyboard/mouse shortcut .ini., but put it to the menu.ini ( When I right click at area of where those labels are )

    Which part in menu.ini I should add to ?

    Thanks much once again !!

    Edmond.
    P.S. Is this forum any longer accept pics insert like the old forum ? and how ?

  • However, from the 1st launch of your command, it does not focus to the properties pop-up dialogue box

    I didn't seem to have this issue. Might be the version of Opera you're using has a bug with that. I would look through the "focus", "Activate" and "Next/prev" commands and see if one of them work.

    If I am to use your command instead of assign to the keyboard/mouse shortcut .ini., but put it to the menu.ini ( When I right click at area of where those labels are )
    Which part in menu.ini I should add to ?

    The "Index Item Popup Menu" section I think. That's where the show_messages_from command is at and you see that when you right-click in the the mail panel (and in the labels section specifically).

  • Thanks burnout426,

    Can you give me a small example on setting the focus, activate and next/pre so that I can join into the command you made for me to start testing?

    As I haven't use in the past any of these opera internal command of activate, next/prev.

    Thanks
    Edmond

  • The commands don't take any arguments, so you can just try them. Just type in the shortcut field while you're editing to look at the auto-complete list.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.