Flashplayer isn't working with Opera... Flash 26 & 27 Opera 46, 48 &49

  • Last week Flash was updated to latest version 27.190 then Opera 49 stopped playing Flash. I tried reinstalling it, but that didn't work, so I tried rolling back the versions of Flash back to 27.130 still didn't work. Tried rolling back to Opera 46. Managed to get it working using Opera 46 and Flash 26. The problem has come back again. I have done clean installs of all but still no luck. Anyone have any ideas?

    Thanks.

  • @steve-edmeades
    Same issues on my Mac.

  • Since Opera 49, flash doesn't work for me either.

  • Same Flash player issue on all sites using to play music.

    This release is broken, we do need a new one ASAP!

  • Known issue.
    See here.
    🙂

  • @davehawley, yeah as it appears this issue is known for several weeks already, since the 49.0 release. And we still can't see any 49.1 fix of that major flaw. This is unacceptable. Nor we don't have a word from Opera on this issue in the devs' blogs.

    Pondering on downgrading to 48 or getting out ol' good (bad) FF. Any news on 50s betas, are they still flash bonkered?

  • I downgraded to the actual working version, for now. If not fixed within a reasonable time - no more Opera.

  • The "always load Flash" option that's in 48 is gone because it and all the code that supports it was removed from Chromium. This part (the setting) has almost a 0% chance of coming back. If it does come back, it'd have to be done in Chromium for Opera to get it back (unless Opera decides to constantly patch in the old code with every Chromium release)..

    What this means is that from now on, you have to go to "Settings -> Websites -> Flash -> Manage Exceptions" to add the site the page is on (and the site the flash swf file is on (if it's on a different domain than the page) ) to get Flash to work for the site / page. This is just how things are now.

    Now, for sites where they try to embed a Flash object in the page (as opposed to not trying if Flash isn't detected via Javascript), and the Flash object isn't hidden, you'll be able to click the Flash object placeholder to pop up the Flash Allow toolbar so you can click "Allow". That way, you don't have to do in manually in settings. For all other situations, you have to do it manually. This is also due to how Chromium behaves. If Opera adds site settings or you use an extension that does it, you'd be able to always add a site exception without manually typing it in.

    Chromium also has site-engagement ratings / stats for each site you visit with media / Flash. See chrome://site-engagement in Opera. The more often you visit a site, the higher the rating is and the higher chance Flash will just load. You can set a site to 100, press enter, close any tabs open for that site and open a tab for that site up again and things will have a better chance to load, even without adding to the Flash exceptions list.

    So, all of that is intended behavior by Chromium.

    However, some users seem to be having trouble in Opera (where they work in Chrome) with the entries in the Flash exception list not working. If you have site examples of this, that would help so Opera can see what's wrong.

    For those that have exceptions that aren't working, some have been able to fix it by closing down Opera and deleting their "Preferences" file in the "AppData/Roaming/Opera Software/Opera Stable" folder (which causes you to loose your bookmarks I think, so export them first). Deleting the whole "Opera Stable" folder to start with a new profile helps for some too.

    Now, since the "Always load Flash" option is gone, you can try this to simulate it. That also works when regular exceptions don't work.

    There's also this flash issue, which seems to happen even in Chrome. This might be intentional for Chromium.

  • Thank you for your detailed response. Goodbye Opera.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.