Google NCR reverts to local

  • Hi all

    I had a post earlier asking about how to add a custom search engine (don't know why it got locked).

    Anyway, it worked for a while then reverted to local google without my having changed it at all. I had to delete it and go through the steps again. Now it's working, but for how long?

    Perhaps I should just know my place and learn to stay there.

  • Opera might release the lock on default search engines... That's how it is on other browsers.

    In the mean time - PM me - I can link you a small extension that does what u wish (uses https://encrypted.google.com on all of Google).

  • @rudrick

    Hi. Thanks for the response. Sorry, I should have been clearer: it was my previous thread on this forum that was locked, rather than anything in Opera.

    Why close a thread just because it has one good answer? I often browse forums looking for solutions and sometimes the answer that worked for the OP won't work for me but another one will.

    And sometimes the solution gets "unsolved" as happened in this case.

    OK, enough whining.

    My original post was asking how to define a custom search engine. I wanted to search the main google site, not the ghettoized one for my region.

    I was advised to navigate to the desired page and right-click on the search field rather than try to mess with the codes in the setup. So I did that, assigned "GO" as the prefix and happily started searching.

    After a while I felt that my results were a bit odd, and looking up at the url found that I was being redirected again to the regional site. I hadn't made any change to the shortcut.

    I tried it repeatedly and never got back to google.com so I had to delete it and start again. Now it works again but I'd like to know what's going on and maybe find an absolutely positively permanent fix (short of using VPN to disguise my location).

  • @mrtasker said in Google NCR reverts to local:

    After a while I felt that my results were a bit odd, and looking up at the url found that I was being redirected again to the regional site. I hadn't made any change to the shortcut.
    I tried it repeatedly and never got back to google.com so I had to delete it and start again. Now it works again but I'd like to know what's going on and maybe find an absolutely positively permanent fix (short of using VPN to disguise my location).

    This?

    "Google has changed the way you can localise searches. While the default option has usually forced you to the local search site - enter google.com and you get redirected to google.com.au - it has been possible to push Google to other locations. (If you wanted a localised British search you could go to google.co.uk, for example.) But now, the company will automatically direct you to your local Google regardless of the address you enter."


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • @zalex108

    Thanks. I read the article and it's interesting, but not the whole story. I'll tell you why:

    I experimentally did a search not attempting to avoid the redirection, and sure enough got redirected.
    I then went into settings and changed country to USA, saved. Made sure cookies were accepted on both the main and regional domain.

    Restarted Opera.

    Did a search without attempted to avoid redirection. GOT REDIRECTED to local site. Checked settings: still say USA.

    So it not only ignores what you key in the url bar, it ignores your regional settings.

  • Then it's depending on the IP.

    Try to use Google with the VPN and change its locations.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.