VPN not working, just "Connecting..."

  • My router updated the firmware and it seems this may be connected to the VPN to stop working on Opera. When I click VPN to turn it on, the button turns orange and it says connecting, but it never connects. The virtual location is optimal but there is no ip address that shows. I reset the router and cleared cache in the browser and rebooted the Windows 10 laptop.

    Anything I can do with Opera to get the VPN to work again?

  • @chialla said in VPN not working, just "Connecting...":

    My router updated the firmware and it seems this may be connected to the VPN to stop working on Opera. When I click VPN to turn it on, the button turns orange and it says connecting, but it never connects. The virtual location is optimal but there is no ip address that shows. I reset the router and cleared cache in the browser and rebooted the Windows 10 laptop.

    Anything I can do with Opera to get the VPN to work again?

    if i may ask, after router updated the firmware.. does opera browse n e websites without vpn on..

  • Yes, the Opera browser works great when VPN is off.

  • @chialla i've notice that if a person has windows firewall if you disable it for a moment while trying vpn.. if vpn starts turn firewall back on might hejp.. While toggling vpn switch on & off 3 or 4 times.. and or n e other apps that might restrict network (just saying..

  • Hey @nvmjustagirl thanks for your ideas. I tried turning off windows firewall defender, saved it, and then tried vpn on Opera. Tried toggling on/off numerous times. Still didn't help. Windows Defender as a list of acceptable apps and Opera is checked as acceptable.

    I'm not sure what else to. Any other suggestions?
    I may uninstall Opera and try re-installing. I'm also talking with support from my router.

  • @chialla
    yes clean install incase you have broken profile..

    Windows Defender Firewall On or Off in Windows 10
    scroll down to Option 4 is simple. heres link..
    .https://www.tenforums.com/tutorials/70699-turn-off-windows-defender-firewall-windows-10-a.html

  • you might clear browser history to beggining of time with all options checked in boxes and disable any extensions if you got any..

  • @nvmjustagirl i opened opera again with vpn off then i turned vpn on and it came on and working for now.. Opera Stable 49.0.2725.39 (PGO)

  • @nvmjustagirl
    Other than that the name leocg will answer to give further help But may be a bit b/4 he can answer.. (am sowwies hope ya get it working soon

  • @nvmjustagirl
    you may need to make new outbound firewall rule to allow opera.exe instead of launcher.exe..

  • the router is not going to block the vpn it'sd part of opera. if opera is getting on line so is the vpn, so that means it the vpn host that's having the problem. i have browsec as well for the times this happens.

  • @chialla didcha get vpn up and run' n on router ? (just ask' n..

  • Thank you for your suggestions. Unfortunately, it's still not working. When I try to enable VPN, the button remains orange with "connecting..." and it does not change or allow access to any site.

    I tried clearing all the privacy settings, disabling extensions, turning off Windows Defender using Option 4. In allowed apps, I noted that "Opera Internet Browser" is checked and Private and Public both have checks. I have not uninstalled and reinstalled Opera, but that would be my last option.

    What is "make a new outbound firewall rule to allow opera.exe instead of launcher.exe"?

    Version: 49.0.2725.39 (PGO) - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit

    chuchkyschild makes sense what you say, but the strange thing was the VPN was working fine, I updated the firmware on the router, the VPN no longer worked. Possible I did something else in that short timeframe that I don't remember, but to me it seems related. I've never had a problem with the VPN in the past.

    Hoping leocg will have sometime to look at this.
    Thanks all for your comments.

  • @chialla i agree with chuchkyschild too and agree with you about your vpn working b/4 firmware update.. i dunno what part of world your in but maybe vpn host is having problems,.. but i doubt it..

    i've noticed lately when vpn 1st connects that it is within this range of ip (162.248.176.0 - 162.248.183.255) On Port 443 not sure about your region..

    so maybe if you could go to start > Command Prompt (admin) to open elavated command prompt and type : ping 162.248.178.119 then hit enter if you get a failure then something could be wrong..

    As for the firewall thingy. i agree with chuchkyschild a day ago
    the router is not going to block the vpn Being that you can browse with out vpn..

    By default, Windows Defender Firewall allows all outbound network traffic unless it matches a rule that prohibits the traffic

  • @nvmjustagirl thanks for your replies. I pinged the address you indicated and got results.

    Ping statistics for 162.248.178.119:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 69ms, Maximum = 70ms, Average = 69ms

    I haven't yet tried to uninstall Opera and reinstall. That's my next option. But before I do that, do you have any other suggestions to get the VPN working again?

  • @chialla said in VPN not working, just "Connecting...":

    I haven't yet tried to uninstall Opera and reinstall. That's my next option. But before I do that, do you have any other suggestions to get the VPN working again?

    On/Off, toggle sites...
    Search on the forums for more info.

    You don't need to uninstall and reinstall, just create a new profile or use the signature's Test profile, fixes most of cases.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Back up Linux · Mac · Win

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.