Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flash player does not work; can not be able.

  • Having the same exact problem since Saturday. A number of flash-based websites stopped working. PPAPI plug-in is still 27.0.0.187 (currently latest). Youtube works fine.
    Settings -> Websites has Flash set to "Ask first (recommended)". No exceptions defined, Allow by default.
    Playing with opera://site-engagement (setting the base to high enough value) FIXES the issue. Same applied to https://helpx.adobe.com/flash-player.html website - it was failing Flash check until the base was raised under opera://site-engagement
    So it does not appear to be a problem with plug-in itself. Somehow the plug-in just gets blocked by the browser for no apparent reason.

    After debugging the issue is seems that the failing part is javascript validation portion of the web page. Specifically, the "navigator.plugins" array is retrieved and there are NO plug-ins found with "Shockwave Flash" in its name. Only plug-ins that pop up are:

    • Chromium PDF Plugin
    • Chromium PDF Viewer
    • News feed handler
    • Widevine Content Decryption Module

    After tweaking opera://site-engagement page - Shockwave plug-in DOES pop up in javascript's navigator.plugins array.

  • @burnout426 said in Flash player does not work; can not be able.:

    chrome://site-engagement

    It finally worked for me( the following comment of @burnout426 ), but I repeated its process for a few times(in my case one time was not successful), in addition to, refreshing website was not enough but also it must be closed and then it must be opened (in my case) and the website's flash player stated working, thanking you.

    burnout426 2 days ago
    I've been playing with chrome://site-engagement more. Setting a site to 0, pressing enter and refreshing that page does indeed remove the site from the list.

    Also, setting a site to 100 (and pressing ENTER to apply it) and refreshing the site's page often allows flash to work without even adding an exception to the list. I say "often" as it doesn't work all the time. Sometimes I have to close out of the tab for the site and open it up again. Other times I have to repeat that stuff a lot of times or refresh the site page a bunch of times. Then it works, again without adding an exception.

    So, maybe try going to chrome://site-engagement and setting all the sites to 100 (making sure to press ENTER each time). Then, for sites where that still doesn't help, keep reloading the site for a while just to see if you can get it to work.

    If a site isn't in the list, go to the site first and then it'll show up. If it still doesn't though, you'll have to try the exceptions list. Then it should show up in the site-engagement list where you can then set it to 100.

    Not a solution. Just something to mess around with. Also, once it works for a page, I'm not sure if it keeps working (after a restart for example) yet. But, it looks like it persists.

  • @shahramop said in Flash player does not work; can not be able.:

    @burnout426

    I would like to ask this question from @burnout426 whehther I am allowed to post your comment in Adobe forum in order to inform and help many other people that have the same problem, please? or I will send you its link by chat and then you can do it by yourself.

  • @shahramop said in Flash player does not work; can not be able.:

    @shahramop said in Flash player does not work; can not be able.:

    @burnout426

    I would like to ask this question from @burnout426 whehther I am allowed to post your comment in Adobe forum in order to inform and help many other people that have the same problem, please? or I will send you its link by chat and then you can do it by yourself.

    Go for it. Thanks for asking.

  • Not 100% sure, but I think the "Allow sites to run flash" option (which is not the default") in Opera 48 uses this setting in the "Preferences" file.

    "default_content_setting_values":{"plugins":1}}
    

    It's right before

    ,"speeddial":{"bookmarks_folder_guid"
    

    in the file for me in a fresh profile (once I set "Allow sites to run flash").

    Since an upgrade removes that option, I tried to set the "Preferences" file to read only to stop the Opera 49 upgrade from removing it just to see if it'd stick long enough to test. But, Opera 49 shows a profile error and resets (or at least removes the setting) from the file anyway.

    I was hoping that the preference was still implemented / supported in the code and the preference was just being removed the first time seen. But, I guess not. Oh well.

  • @jendenbm said in Flash player does not work; can not be able.:

    Having the same exact problem since Saturday. A number of flash-based websites stopped working. PPAPI plug-in is still 27.0.0.187 (currently latest). Youtube works fine.
    Settings -> Websites has Flash set to "Ask first (recommended)". No exceptions defined, Allow by default.
    Playing with opera://site-engagement (setting the base to high enough value) FIXES the issue. Same applied to https://helpx.adobe.com/flash-player.html website - it was failing Flash check until the base was raised under opera://site-engagement
    So it does not appear to be a problem with plug-in itself. Somehow the plug-in just gets blocked by the browser for no apparent reason.

    After debugging the issue is seems that the failing part is javascript validation portion of the web page. Specifically, the "navigator.plugins" array is retrieved and there are NO plug-ins found with "Shockwave Flash" in its name. Only plug-ins that pop up are:

    • Chromium PDF Plugin
    • Chromium PDF Viewer
    • News feed handler
    • Widevine Content Decryption Module

    After tweaking opera://site-engagement page - Shockwave plug-in DOES pop up in javascript's navigator.plugins array.

    Disable pepperflah in chrome and enable shockwave..

  • Has anyone tried:

    "C:\Program Files\Opera\launcher.exe" "--ppapi-flash-path=C:\Users\user\AppData\Local\Google\Chrome\User Data\PepperFlash\27.0.0.187\pepflashplayer.dll" "--ppapi-flash-version=27.0.0.187"
    

    to see if pointing Opera to Chrome's pepperflash dll makes a difference? It should be the same file as the one in the system32\macromed folder. However, the one in the macromed folder isn't named exactly "pepflashplayer.dll" and doesn't have the manifest fingerprint and the metadata fingerprint folder along with it like Chrome's does. It's a long shot, but that might trigger better behavior.

  • @burnout426 @shahramop The problem come back again after using Ccleaner in order to clean the PC and the browsers and again the above process over "chrome: // site-engagement"must be repeated.

  • @shahramop said in Flash player does not work; can not be able.:

    @burnout426 @shahramop The problem come back again after using Ccleaner in order to clean the PC and the browsers and again the above process over "chrome: // site-engagement"must be repeated.

    Ccleaner probably removes those settings from the Preferences file by removing the whole "site_engagement":{} block. Either that or when Ccleaner clears the history, it causes those settings from the Preferences file to be invalidated where Opera then removes them.

  • @nvmjustagirl said in Flash player does not work; can not be able.:

    Disable pepperflah in chrome and enable shockwave..

    I'm not using chrome so it doesn't apply.

  • Well folks I have been reading posts in this topic and I think maybe I can give some help here.
    Firstly I want to inform everyone that I use the 3 versions of Opera (Stable, Beta and Developer) in both Windows and Linux.
    No, I do not sync up because each of these browsers on each system has a different set of open tabs.
    Initially after opening a topic and reading others like this regarding the same problem it is not to initialize Flash even though the site is in the Flash exception list that you access through the Opera settings.
    One of the people posted relevant information and from there I came up with the solution that I applied in all versions in both operating environments with almost 100% success.
    The workaround is to delete or rename the Preferences file that is in the root directory of the Opera session that you are using.
    The bad part is that you lose the information of the installed extensions having to reinstall again.
    But I said it did not work 100%.
    It really did trouble the Opera Stable session in the Linux environment.
    I simply did not have access to the installed extensions page anymore.
    And the funny thing is that opening this session with Opera Beta or Developer the problem did not occur but the sessions of others that were normal also presented the same problem when opened by Opera Stable.
    Uninstalling and reinstalling Opera Stable did not work.
    So I did an experiment that, at least for me, worked very well.
    I renamed the folder with the Opera Stable session under another name and then started the Opera Stable.
    He created a new session.
    I closed Opera and then copied the following files from the old session to the new session:
    Bookmarks, Current Session, Current Tabs, History, Last Session and Last Tabs.
    I started the Opera Stable again and then it opened the same tabs as the old session with visitor history intact.
    I do not care about saved passwords even because I disable this option which may be something bad for you that reads this my post.
    Also the extensions of the old session are not there but I find it more important to save all open tabs and history than installed extensions or saved passwords.
    This is the tip of having this option and I suggest keeping the folder of the old session until you are sure that everything is working well.
    And remembering that when doing this you will have to insert into the Flash exception list all the URLs that you want Flash to be allowed to run.

  • @msxmaniac I tell the experience one of my friends in this case, having the same flash player problem, he had done the same to rename the folder called Opera Stable , for which the opera must be closed otherwise it can not be done, after that he was not able to open the Opera, after uninstalling it neither he was not able to reinstall opera, trying to reinstall it for several times that had been led to damaging its Window 10, as result of it, he had to call a PC expert to reinstall his window.

    Before him, I had done the same, fortunately nothing happened to me, in this sense I renamed the Opera Stable folder to "Opera Stable Old" that led to an Opera without my bookmarks and extensions, but the above flash player problem had not been fixed, and so, changing the Opera Stable Old folder to that previous one of"Opera Stable" deleting new created Opera Stable I came back to my usual Opera without tolerating any damage like my friend(I had lost only my extensions that I reinstalled them again). this workout did not function for me.

  • Try this:

    • Remove all exceptions from the Flash exceptions list.

    • Set every site in chrome://site-engagement to 0 to clear them. (Just so you can try if the following really works.(

    • Add an exception for each top level domain you want:

      [*.]com
      [*.]info
      [*.]org
      [*.]net

    Then try things.

    It seems to work for me so far. It doesn't solve this problem, but it seems to work in general.

    When having an exception list like this, I notice that some times, neither radio button for the flash preference in settings is selected. Don't know what that means, but noticed it.

    You can also try the solution proposed in this post

  • @burnout426 It works, thanks man. Opera messed something up with top bar notification for flash plug-in, click-to-play is also not working as it was previously. I have flash installed but Opera was unable to use plug-in or even ask me to use a plug-in because it was not allowed to run. Ridiculous.

  • @shahramop I'm really upset about the stories.
    Simply renaming the folder by forcing Opera to create a new one meant a new session should not cause so much trouble, not even uninstalling and then reinstalling the browser, much less having to reinstall the entire system, although Windows has a bad fame to get lost in the dust.
    The fact that you did what I did and did not work out is also worrying.
    It is true that with Opera on Linux I just did not open the extensions page anymore, forcing me to have to create a clean profile and as I said after I created it I copied the Bookmark files, Current Tabs, Current Session, History, Last Tabs and Last Session of the old profile on those of the new profile and worked everything perfectly.

  • @msxmaniac said in Flash player does not work; can not be able.:

    @shahramop I'm really upset about the stories.

    Antivirus settings, dirty registry system, playing with browser settings/flags and forget it...

    Many things may be involved and the fixes may wont work for some users.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • @zalex108 msxmaniac, zalex108, Please tell these to the Opera organization that does not respond to the users( I am one of them) that have the problems; to the Opera organization that reads this forum and does not fix the problem giving a new update, the mentioned about workouts are belong to commenters in this forum that I tried to use them and telling the result of it.

  • @msxmaniac First that PC damaged (its Window) was belong to one of my friends, and not me and I told you whatever I heard, second before of this present Opera problem his PC worked well, facing this problem using different workouts suggested by the other people making him nervous making a mistake led to such PC damaging, I told him that he must listen to workout of any person that is not PC expert changing or renaming the folder of the PC that could create mistakes damaging the PC and if you are a PC expert and sure that tens of times changing and unstalling and reinstalling.........renaming the folders in a PC do not led to such accident in connection with the above "stories" for which you are "upset", please make a new update for Opera fixing the problem in order to come an end to this problem, please do not upset for that story because my friend had to pay to the PC expert for the reparation and money is not important but also the issue was this that fortunately he did not lose his document and important files.

  • @shahramop said in Flash player does not work; can not be able.:

    @zalex108 msxmaniac, zalex108, Please tell these to the Opera organization that does not respond to the users( I am one of them) that have the problems; to the Opera organization that reads this forum and does not fix the problem giving a new update, the mentioned about workouts are belong to commenters in this forum that I tried to use them and telling the result of it.

    I'm one of the commenters/users, so can no't help on this.

    At the other hand I suppose they read this topic.
    Despite the FlashPlayer dropping future, some help should be given.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • Another update today and still no flash without playing with the workaround. I'm beginning to think that the devs don't give a darn about user complaints like so many other developers these days. 🙄