Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera not working (black screen) since Windows Update 1709

  • Opera not working after Windows Update to 1709.
    Opera starts up and at first looks ok, but browser window just shows black, no matter whether calling a webpage or on bookmarks, settings, etc.

    Uninstalled Opera and deleted User Settings.
    Cleaned all Opera related entries from Registry.
    Installed Opera 48.0.2685.52

    Same problem as above.

  • Same here... and I can;t find a fix anywhere!!!!

  • HW acceleration, GPU Drivers...

    Check that.

    Try with Snappy drivers also if needed.

  • Here the Problem was fixed with the newest nVidia Optimus driver.
    Opera is now fully functional again.

  • 👍

  • This post is deleted!
  • I had the same issue and the way you solved your problem isn't doing anything for me, yet my post was locked. (^:
    I have updated my drivers. My computer runs Quadro 1000M and is fully updated. there is nothing else I can think to do.

    I only made a separate post because I've yet to fix my issue, I've been looking all over for a way to fix it.

  • @besottedboy
    Have you turned hardware acceleration off?
    That has worked for others as a (hopefully temporary) workaround.
    Run "launcher.exe --disable-gpu" and if Opera then appears properly, turn it off in the settings.
    🙂

  • I'm using Opera for years. But after latest Windows10 uptade my screen goes black when i use Opera. But when i plug in my tv opera doesnt cause black screen. What's going on my Opeara?

  • @kodderzen The solution I found was going to my device manager and uninstalling my nvidia and then restarting the computer. AFTER I had already upgraded it.

    It'll reinstall itself upong rebooting and it fixed my problem so! This was nice for me. (:

  • @besottedboy it hasn't worked for me. I updated my drivers but could't get solution. When i plugged my computer to my tv with HDMI, Opera is flawless. It's very interesting.

  • @simoncrowder Late reply but I found this thread when looking for a solution for Opera.
    Same problem with black window on my Lenovo W520 with a Quadro 1000M.

    Solution is to set the Opera application to use the integrated graphics using the Nvidia Control Panel.
    These are the steps:

    • Open Nvidia control panel; C:\Program Files\NVIDIA Corporation\Control Panel Client\nvcplui.exe
    • choose "Manage 3D settings"
    • then the tab "Program settings"
      1. Add Opera application if it is not in the drop down list
      1. Choose "Integrated graphichs"
        That is it!

    You can also add more applications in the list that have problems with the Quadro 1000M.

Locked