[Opera Mail] Sometimes messages are missing from IMAP inbox

  • Hi,

    I encountered a strange problem with Opera Mail 1.0 .. I noticed, that some mails are not showing up in my inbox when checking mails with Opera Mail, but they show up when checking with my mobile phone or via web access.

    I'm accessing mails via IMAP on all devices and have over 12000 mails stored in my inbox. Junk mail folder is empty, so the missing mail are not flagged as spam or something. When I delete one of these "invisible" mails via smartphone they appear in the trash folder on all clients including Opera Mail. Occasionally I get old messages from my inbox marked as unread, too. I guess the two effects have the same cause.

    Anyone with an idea how to fix this?

    Thank!

  • You could try deleting/removing the account from Opera Mail and recreating it.

  • Make sure you're not using low-bandwidth mode. That will mess up synchronization. The setting is on the "Incoming" tab in the account's properties.

    Then, enable logging to see if you see "QRESYNC" anywhere in the log. If you do (or if you just want to skip logging), close down Opera Mail and edit incomingN.txt in the mail folder (where N is the number for the account as seen in accounts.ini). Set Disable QRESYNC to 1 if it's not already set to 1 already.

    If it was already set to 1, you can try to force a single connection. If that doesn't help, you can try t disable UIDPlus. But, turn it back on if that doesn't help.

    After you switch a setting in incomingN.txt, click the check/send button drop-down on the mail panel toolbar and choose "resynchronize" to see if that helps. But, if you want to be really sure if the change in settings is helping, it'd be best to delete the IMAP account and add it back in. Or, for folders besides Inbox, goto "menu -> mail -> IMAP folders" unsubscribe and resubcribe to each folder. However, the best thing to do would be to close down Opera, rename the mail folder, start Opera back up, add your IMAP account back in (but don't put a username and password in yet), click on the "Inbox" for the account to try and connect (but don't put a username and password in yet), close down Opera, modify incomingN.txt and then try things out.

    QRESYNC should be disabled by default for new accounts in Opera mail though. If you imported from old Opera though, that might not be the case.

    So, most likely, it's a QRESYNC issue or your mail folder is just messed up or it's a UIDPLUS issue.

  • Thanks the both of you, I tried the QRESYNC thing, but that didn't fix it. After deleting the account as well as the whole folder in C:\Users***\AppData\Local\Opera Mail and setting everything up again, the missing mails turned up again. So I suppose the problem will not turn up again :)

  • Make sure that in the account properties on the IMAP tab the Sent, Trash, Spam correspond whit Sent, Trash, Spam from The IMAP server for opera to sort those mails accordingly

  • Hi,
    I'm using Opera Mail for short time but i have similar problem:

    • I have 2 IMAP accounts - gmail and outlook.com (hotmail)
    • Gmail works fine
    • outlook.com got IMAP support for few months now, but my emails are missing:
      After setup outlook.com account in Opera Mail, whole emails are syncing without problem (about 1200 emails), but when i close and reopen Opera Mail then everytime Opera deletes about 400-500 newest emails in my INBOX folder, when i hit button to check this account Opera downloads them again, after that i close Opera, same day opens Opera and my emails in INBOX are gone again.

    I was trying deleting account / changing UIDPlus (QRESYNC disabled by default)

    PC Specs:
    Lenovo G570 (Intel Core i3)
    Windows 8.1 64bits
    User with full privileges
    Opera Mail v1.0 build 1040

    P.S. Mozilla Thunderbird works fine without losing any emails, but i liked Opera Mail for its simplicity and fast launching

    Thanx for any advice, and sorry for my bad english.

    Regards.
    wpinacz

  • i have similar problem

    Download the opera mail installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation (USB)" and install.

    Set up the outlook.com IMAP account in it and see if it works fine there. If so, you just need to delete your mail folder in your normal Opera profile and set things up again.

    If it is still messed up in the standalone installation, turn on logging and see if you can find something wrong.

    Make sure you don't have low-bandwidth mode turned on for IMAP though. It messes with syncing.

  • Hello,
    I've been trying Your solution but with no go...

    Opera Mail still deleting my emails in INBOX folder, I have enabled logging and heres the output:

    https://dl.dropboxusercontent.com/u/103423538/opera_mail_log.txt

    I have trimmed log, it ends in moment when log contains message contents, also email address is hidden (as XXXXX@XXXXX.COM
    Hope someone halps with this strange problem.

    Regards,
    wpinacz

  • Will have to look at the log more. But, close down Opera and edit incomingN.txt in the mail folder (where N is the number for the account as seen in accounts.ini). Set Force Single Connection to 1. (It was needed for hotmail a while ago. Might be needed for Outlook.com's specific IMAP implementation (if it's any different).

    I don't see anything weird in the log. Might be something after you trimmed though.

    You might want to look for where the \Deleted flag was added to any messages. It'd be in a request ("out") from Opera and would have:

    store range +flags \Deleted

    or

    store range +flags (\Deleted other_flags)

    or just

    store range flags {\Deleted other_flags|

    Those commands may or may not have UID in them.

    Opera might then send an EXPUNGE request (a single one or one or more with UID in them).

    You'd see those in comments for the INBOX.

    Before you see those commands though, you might see UID Copy commands that copy the messages from the INBOX to the trash folder. Then, you'd see those \Deleted + expunge commands in the INBOX to delete the orignial copies. Then, if the trash then gets emptied, you might see more \Deleted and expunges requests from Opera.

    If you're not seeing any of that, the messages could appear to Opera as just being gone from the server for some reason and Opera is just syncing and cleaning up messages that it things (or the server things when Opera is the client) that are no longer there.

    Also, make sure you disable the spam filter for the account on the IMAP tab in the account's properties.

  • I'm having the same problem. When I restart Opera Mail all my messeges are resync. If I trun to Low Band Mode this not happen..

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.