Enable dark theme in private mode + google translate selected text

  • Both requests for Opera for Windows.

    1st:
    It is just common sense really. Why would you include dark theme and then make it impossible to use in private mode?
    If someone don't want to use it, he can disable it in options.

    2nd:
    Please add 3rd option for selected text, "google translate" (search, copy, google translate).
    This would be very useful to be able to translate selected text without c/p text to new tab where you need to load google translate first. And it would be way faster.

  • Ok, I see developers think this is not necessary, so let me ask them then. Why do you think there shouldn't be dark theme in private mode? I am sure you have good reason so lets hear.

  • Still devs don't want to clarify this, why no dark theme in private mode?

  • Still devs don't want to clarify this, why no dark theme in private mode?

    I use dark theme in private mode from the getgo using Windows7 with Opera Stable, beta, and dev streams.

    Try adding a parameter to the target line of Opera shortcut properties. Leave one space and add "-private" (without quotes), click Apply then okay and restart. Opera will then always startup in private mode. Ensure dark theme is enabled.

    There have been some changes to the dark theme in dev v49. Check it out.

  • I use latest stable Opera 64 and Win 10 64.
    Can you post how should full target line look like in order to start in private mode and dark teme enabled?
    I tried adding -private but no luck.

  • Can you post how should full target line look like in order to start in private mode and dark teme enabled? I tried adding -private but no luck.

    Ensure Dark Theme is checked in settings. To start in private mode is as mentioned (ie: after adding parameter ->apply ->ok, and restart. Clicking the taskbar icon will 'start' in private mode - meaning that's your shortcut to it).

    No problems for me on Win7 32-bit, or Win10 (v1703) 64-bit, and it's a straightforward modification of the shorcut.

  • I get the warning msg every time I try to modify target line with this -private. Can you please post exactly how should target line look like?

  • I get the warning msg every time I try to modify target line with this -private.

    What warning message? Post your example?

    Can you please post exactly how should target line look like?

    For example, among others, I have Opera portable [on USB] but also placed its shortcut on home PC. After modifying shortcut properties target line looks like this:

    • E:\Opera\launcher.exe -private

    I have no further ideas to assist you.

  • It says that name specified in Target box isn't valid. And therefore I am unable to confirm apply or ok, I can only cancel. Nevermind. Thanks anyway.

  • It says that name specified in Target box isn't valid. And therefore I am unable to confirm apply or ok, I can only cancel. Nevermind. Thanks anyway.

    If you're using C drive, then you would see Opera shortcut properties target line as C:\Opera\launcher.exe

    Simply leave one space after it and add -private so target line becomes C:\Opera\launcher.exe -private

    "Apply" is only available if you choose to modify the shortcut. Maybe you should try Opera reinstall.

    Be aware the shortcut target line may change slightly when Opera auto-updates.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.