Opera crashes on video services and gmail

  • Trying to view any youtube related video on any page cause crash.
    Same problem on gmail - after login the browser is trying to connect something at google and... crash
    No problem on the same computer using Safari...

    Opera Version: 46.0.2597.57
    VPN - on
    Extensions - disabled
    Mac OS X: 10.10.5 64-bit

    some gpu info
    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated
    Driver Bug Workarounds
    add_and_true_to_loop_condition
    adjust_src_dst_region_for_blitframebuffer
    decode_encode_srgb_for_generatemipmap
    disable_av_sample_buffer_display_layer
    disable_framebuffer_cmaa
    disable_multimonitor_multisampling
    disable_webgl_rgb_multisampling_usage
    emulate_abs_int_function
    get_frag_data_info_bug
    init_one_cube_map_level_before_copyteximage
    msaa_is_slow
    pack_parameters_workaround_with_pack_buffer
    rebind_transform_feedback_before_resume
    regenerate_struct_names
    remove_invariant_and_centroid_for_essl3
    reset_base_mipmap_level_before_texstorage
    rewrite_do_while_loops
    rewrite_float_unary_minus_operator
    rewrite_texelfetchoffset_to_texelfetch
    scalarize_vec_and_mat_constructor_args
    set_zero_level_before_generating_mipmap
    unfold_short_circuit_as_ternary_operation
    unpack_alignment_workaround_with_unpack_buffer
    unpack_image_height_workaround_with_unpack_buffer
    use_intermediary_for_copy_texture_image
    use_shadowed_tex_level_params
    use_unused_standard_shared_blocks
    Problems Detected
    Multisampling is buggy on OSX when multiple monitors are connected: 237931
    Applied Workarounds: disable_multimonitor_multisampling
    Unfold short circuit on Mac OS X: 307751
    Applied Workarounds: unfold_short_circuit_as_ternary_operation
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Mac drivers handle struct scopes incorrectly: 403957
    Applied Workarounds: regenerate_struct_names
    On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
    Applied Workarounds: msaa_is_slow
    glGenerateMipmap fails if the zero texture level is not set on some Mac drivers: 560499
    Applied Workarounds: set_zero_level_before_generating_mipmap
    Pack parameters work incorrectly with pack buffer bound: 563714
    Applied Workarounds: pack_parameters_workaround_with_pack_buffer
    Alignment works incorrectly with unpack buffer bound: 563714
    Applied Workarounds: unpack_alignment_workaround_with_unpack_buffer
    copyTexImage2D fails when reading from IOSurface on multiple GPU types.: 581777
    Applied Workarounds: use_intermediary_for_copy_texture_image
    Multisample renderbuffers with format GL_RGB8 have performance issues on Intel GPUs.: 607130
    Applied Workarounds: disable_webgl_rgb_multisampling_usage
    Mac Drivers store texture level parameters on int16_t that overflow: 610153
    Applied Workarounds: use_shadowed_tex_level_params
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    glGetFragData{Location|Index} works incorrectly on Max: 638340
    Applied Workarounds: get_frag_data_info_bug
    glResumeTransformFeedback works incorrectly on Intel GPUs: 638514
    Applied Workarounds: rebind_transform_feedback_before_resume
    glTexStorage* are buggy when base mipmap level is not 0: 640506
    Applied Workarounds: reset_base_mipmap_level_before_texstorage
    Result of abs(i) where i is an integer in vertex shader is wrong: 642227
    Applied Workarounds: emulate_abs_int_function
    Rewrite texelFetchOffset to texelFetch for Intel Mac: 642605
    Applied Workarounds: rewrite_texelfetchoffset_to_texelfetch
    Rewrite condition in for and while loops for Intel Mac: 644669
    Applied Workarounds: add_and_true_to_loop_condition
    Rewrite do-while loops to simpler constructs on Mac: 644669
    Applied Workarounds: rewrite_do_while_loops
    AVSampleBufferDisplayLayer leaks IOSurfaces on 10.9.: 632178
    Applied Workarounds: disable_av_sample_buffer_display_layer
    Do TexImage2D first before CopyTexImage2D for cube map texture on Intel Mac 10.11: 648197
    Applied Workarounds: init_one_cube_map_level_before_copyteximage
    Decode and encode before generateMipmap for srgb format textures on macosx: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    Insert statements to reference all members in unused std140/shared blocks on Mac: 618464
    Applied Workarounds: use_unused_standard_shared_blocks
    Tex(Sub)Image3D performs incorrectly when uploading from unpack buffer with GL_UNPACK_IMAGE_HEIGHT greater than zero on Intel Macs: 654258
    Applied Workarounds: unpack_image_height_workaround_with_unpack_buffer
    adjust src/dst region if blitting pixels outside read framebuffer on Mac: 644740
    Applied Workarounds: adjust_src_dst_region_for_blitframebuffer
    Mac driver GL 4.1 requires invariant and centroid to match between shaders: 639760, 641129
    Applied Workarounds: remove_invariant_and_centroid_for_essl3
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Rewrite -float to 0.0 - float for Intel Mac: 672380
    Applied Workarounds: rewrite_float_unary_minus_operator

  • The problem is with Flash content. Wherever it is Opera crashes. Only Neon works.
    Any ideas??

  • I use Opera Mac and have the same problem: browser freezer when trying to load Youtube, Google, Facebook or other pages. Interestingly, DuckduckGo doesnt crash. The problem doesn't occur when using incognito mode.

    Tried disabling all extensions, no effect. Also, have Flash disabled by default, so not the problem either.

    Just minutes ago Opera updated itself and I restarted it. Problem persists.

    Version: 47.0.2631.55
    Source: Stable
    System: Mac OS X 10.11.6 64-bit

  • I found that the problem doesn't happen when disabling Opera's adblocker. So, stick with 3d party ones.

    Regards

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.