:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

OPERA MAIL problem with downloading old messages

  • I use Opera (with mail client) since 2008 (about 25 GB and 10.000 mails). And after checking new messages it shows that "fetching messages ../20" and after that shows communicate "no new messages received". For me it's a problem because process last about 10 minutes and i presume opera downloads it phisically but not shows. How to fix it?
    However after receiving a new message opera shows it but afterwards shows downloading lost 20 messages.

  • IMAP or POP?

    Low-bandwidth mode?

    If IMAP, is "do not download attachments" set?

  • POP
    No Low-bandwidth mode
    Besides it downloads brand new messages but some old stil "see" as not downloaded.

  • Hard telling what the actual problem is, but...

    In opera:config under the mail section, set Mail Database Consistency Check Time to 0, save and close Opera. When Opera asks, tell it to go ahead with the check. Opera will then scan and fix what it can.

    You'll just have to look at disk activity to tell when Opera's done. When it's done though, you can look at recovery.log in the mail folder to see what it found and fixed. You'll want to look at the last scan in the file.

    The value for the setting will change from 0 when you start Opera. Don't worry about that.

    If that doesn't fix it, download the Opera installer, launch it, click "options", make sure "install path" is set to your existing Opera so it says "upgrade" and install. That'll fix any program file issues.

    Also, you might want to check your disk for corruption.

    Also, you might want to defrag the mail folder. Easy way to do this is to move the mail folder to another drive and then back. Or, you can copy the the mail folder, delete the original and then rename the copy to "mail". Or, you can just degrag your drive.

    If that doesn't fix it, you can delete the uidl file in the pop3 folder in the mail folder. The uidl files are numbered by account as seen in accounts.ini. What this will do is cause Opera to refetch all messages in the Inbox and it should also fix any fetching problems. But, you might end up with some duplicate messages where you have to delete the old ones and keep the new ones.

    If that doesn't do it, you'll have to start with a new mail folder, set up your accounts again and import the messages from the old mail folder into the accounts in the new mail folder.

    But, you might want to close down Opera and edit accounts.ini in the mail folder. Under the section for the account in question, add the "Incoming Log File=" line and set its value to the path to a text file on your desktop. Then, start Opera and have it check/send. Then, look at the log to see if it reveals anything. It could just be a single message on the server that Opera doesn't like. If you have IMAP or webmail, you might want to move all messages in the Inbox to another folder temporarily, check/send in Opera and then move them back to the Inbox so Opera can fetch them again.

    Also, on a side, in opera:config under the mail section, you might want to uncheck "Load Mail Databases Asynchronously" so that the mail database loads up really fast at startup.

    Also note that the "fetching..." status isn't always accurate (or at least looks like it's not always accurate). I'd just ignore that if all your messages are actually there. if so, then it's just a case of trying to make the syncing faster.

  • Also, in "All Messages/Received", you might want to click the "settings for this view" button on the toolbar above the message list and check all the "show" boxes and search for the messages in question to make sure they're not just hidden.

    Also, in "shift + F12 -> buttons -> mail/mail view", there's a period button/dropdown. Drag it to the toolbar above the message list. Then, open each message list and make sure the period is set to "forever'. If one or more views are not set to forever, that might be the problem.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.