Opera mail problem

  • My email server had an issue that forced me to restore it to a day old back up. Since then, opera mail is no longer retrieving pop email messages. It logs in without a problem, but somehow it always thinks there are no messages to retrieve. If I use Live mail, the emails are found without issue. If I create a duplicate email account on opera mail, it retrieves the emails without a problem. Only the original account doesn't work. If there was some way to move the sent mail folder items from the original account to the duplicate account, I would just do that and delete the original account, but there appears to be no way to accomplish that. Any thoughts?

  • If there was some way to move the sent mail folder items from the original account to the duplicate account, I would just do that and delete the original account, but there appears to be no way to accomplish that

    Right-click on the "Sent" view for the account in the mail panel and choose "Export" to save the view as "sent.mbs". Then, goto "Menu -> settings -> import and export -> import mail -> import generic mbox". Choose "sent.mbs", set "sent.mbs" in the "move to sent" drop-down and set "import into" to the duplicate account.

    The other way to fix it is to close down Opera and delete a file in the pop3 folder in the mail folder. See help -> about Opera Mail for the location. In the pop3 folder is a uidl file for each pop account. They're numbered according to the accounts in accounts.ini. You can just delete the one for your original account and Opera will redownload all messages in the Inbox and fetching will work fine then. If you then have duplicates (new copies and old copies), you need to delete the old copies as they're no longer tied to the copies on the server.

    The reason this happens indeed has something to with the changes on the server. Something with the ids of the messages the server sends changed and Opera got confused. I think technically, the server is supposed to keep them valid when restoring from a backup, but not all servers do.

  • Thank you so much for your help! That fixed the problem.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.