Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

With Google search in address bar cannot move to next page of results

  • Opera beta 42.7.2246.114995
    Opera stable 37.0.2192.105088
    Android 5.1
    Verizon Ellipsis 10 tablet in Tablet and desktop mode

    Don't know exactly when this started, but it was some time this month.

    With Google as default search engine, after typing a search term in address bar and retrieving results, clicking next at bottom of page "hangs" (screen dims and next page is not displayed). Sometimes clicking 2 will move to next page, but can't move after that. Problem does not occur with Agent set to Mobile. Bing and Yahoo work okay as default. Typing full url search in addresss bar " etc." or entering search from Google home page (which puts the same data in address bar) works ok and the problem is not manifested.

    Obviously Google changed something, but the problem does not occur with my six other browsers (Chrome-latest, Chrome beta-latest, Firefox 49.0.2, Firefox beta-latest, Naked browser-latest, and Naked browsser pro-latest).

    I tried clearing cache (all apps) and clearing cookies & data. Also tried enabling some flags (experimental javascript, experimental web platform, and experimental webgl). Didn't try reinstall because I don't want to have to re-enter passwords.

  • I have this same problem with Opera beta 42.7.2246.114996 with "desktop" user agent.

    The URL that the default Google search engine generates for a search for "fun" is this, which exhibits the reported problem:

    This URL exhibits the expected behavior (ability to click to different pages of search results):

    My suspicion is that the URL that Opera generates doesn't properly work, causing the problem.

    A (poor) solution is to add Google search to the search engines (long press on text box on and then select that instead of the pre-added google search. Downside being that you can't set the default to your custom search engine, so you have to select from the search engine drop down every time.