Opera 12 opening when I want to use Opera 20

  • I'm having a bit of a frustrating occurrence at the moment. I use Opera 20 on Mavericks but retained my old Opera 12 install in my applications folder. Certain apps and links have a tendency to open Opera 12 instead of or as well as Opera 20. Of particular frustration is 1Password, which has a handy quick login functionality but which simultaneously opens both versions. How can I dissociate Opera 12 from my workflow? I have data in notes and things which I'd still like to have access to. I've renamed it, moved its location - no dice.

    Any tips?

  • I've got both installed with no problems.

    My Opera 12 is still in the Applications folder and is renamed OperaOld.app.

    You could try starting Safari (if you still have it installed) changing that to the default browser.

    Then launch Opera 20 and make that the default browser, having renamed 12.

    I would think do a system-wide change which would stop the conflict.

    Purely speculation though!

  • Ok, it just happened to me with Dropbox.

    Think I've found a workaround:

    You need to rename the executable file not the app.

    Here's what I've done:

    Rename the app "Opera12"

    Right click and 'show package contents' > Contents > MacOS

    In there is the executable file - rename that "Opera12"

    I did some other stuff with profiles while I was messing around so it may be slightly more complicated than that. Let me know if it doesn't work.

    It may break your links or have other consequences, but works fine for me.

  • Are you sure you have set Opera 20 as your default browser. Go to opera://settings/ and click on "Make Opera my default browser".

  • Here is a safer way to keep the two separate:

    Open the file “Opera 12.app/Contents/Info.plist”. Find the Bundle ID and change from “com.operasoftware.Opera” to “com.operasoftware.OldOpera”. The OS will no longer have a problem telling them apart.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.