flash issues with opera in openSUSE Leap 42.2

  • not really sure what the issue is here, but some flash works, and some doesnt...
    facebook videos are broken, cant play anything from soundcloud, and animated gifs are hit-or-miss as well.
    youtube still works though, probably because of html5 right?
    my plugins page shows Adobe flash 22.0 is installed, and i enabled flash to run in the browser settings but im still stumped...

  • Hi @perforatedpaper,

    facebook videos are broken, cant play anything from soundcloud, and animated gifs are hit-or-miss as well. youtube still works though, probably because of html5 right?

    These are all examples of sites that use HTML5 video, not Flash. Then it starts depending on which codecs are being used. YouTube works because they use the patent-free VP9 codec to offer videos in. Facebook and 'animated gifs' (actually not animated gifs) aren't working for you because they use the patent-encumbered H264 codec, which Opera doesn't have the right to redistribute.

    You'll need to install a suitable Chromium ffmpeg codec pack to display these videos. In Ubuntu this is the chromium-codecs-ffmpeg-extra package, I don't know what packages are out there for OpenSUSE, but maybe this can help you find it :).

  • Hello I've some similar problem, crunchyroll didn't let me play any videos, I install flash player as seen here and after I installed those that @avl said, and then I installed flash-player-ppapi using YaST and that let me watch videos correctly.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.