Opera beta taskbar icon is opening another icon - why?

  • Just updated Windows from 1511 to 1607 and found a couple of changes within Opera (beta). One I'm not understanding and haven't been able to fix is why when I open Opera beta from its taskbar icon, it's opening another icon. Why? If you're thinking, why not just pin it and unpin the other, the reason is I have added "alt-high-dpi-setting=96" to launcher.exe for both desktop and taskbar icons, but the new one, when pinned, isn't recognizing that and doesn't show any properties to know where it's launching from. Any ideas Opera is acting this way?

  • Here's a screenshot of it: middle is existing icon, right is new one created. Note the latter is also different.

  • Forgot the link: http://tinypic.com/m/jq3hib/1

  • Your taskbar icons should be here -
    C:\Users\Username\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar
    If you can identify the rogue shortcut in that folder you should be able to edit its properties there.
    🙂

  • Thanks, Dave. I was familiar with that folder in creating an XP style quick launch toolbar starting in Win 8, but had never paid attention to the location of the official left side lnk files. But on this subject, in looking at the Quick Launch folder I don't see my XP style toolbar folder there, as it was under Win 8.1. It should be, according to these instructions: http://mywindowshub.com/add-quick-launch-toolbar-windows-10/. Any ideas?

  • I realize this is not an Opera problem and hence off topic, but if you have any ideas... Here's a link to a screenshot that shows three things: 1) the current quick launch toolbar (taskbar right side); 2) the quick launch folder contents now in Win 10 (left in file mgr); and 3) the quick launch folder contents I had in Win 8.1 (right in file mgr). Note how the current toolbar set corresponds to what's on the toolbar now, but not to what's in the Win 10 version folder.

  • I've since discovered from pinning the second icon that it's starting from the opera.exe file instead of launcher.exe. It's called "Opera beta Internet Browser.lnk" and the current target is..."C:\Program Files\Opera beta\43.0.2442.52_0\opera.exe" The pinned icon with dpi suffix is also opening a second tab: http://-/, which obviously can't be reached (error message).

    I can modify each version with the dpi string, but why does the second icon exist and reference opera.exe instead of launcher.exe?

  • Sorry I can't help with the Quick Launch problem, maybe something was changed in the Windows 10 Anniversary Update that is now preventing it from working? I think the update broke quite a few tweaks like that.
    I think there have been other mentions of spurious duplicate Opera icons appearing on the Windows 8/10 taskbar, but if you have one that works correctly, why not just delete the faulty one? The correct icon should definitely point to launcher.exe, not opera.exe.
    🙂

  • Don't think you quite understand the full problem. The faulty one is the one that shows when Opera is started, hence deleting it closes the program. It starts from opera.exe instead of launcher.exe and opera.exe does not take the dpi add on, so there's no use in pinning it.

  • Ah sorry, I see now.
    I think I would now back up my profile folder and then uninstall Opera, and find and delete any remaining folders and files relating to it, including all the shortcuts. Cleaning the registry of all Opera entries would be a good idea too (back it up first of course!)
    Then reinstall Opera and see if the problem is still there with a clean new profile.
    If it is, I can only assume it's a problem between Opera Beta and Windows 10, which I would have thought others would be experiencing too.
    If it fixes it I would assume that something had got corrupted with the Windows 10 update, for reasons unknown.
    You can then delete the new profile and replace it with your saved one, and hope that doesn't bring the problem back!
    If it doesn't, all should be well.
    🙂

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.