Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to stop saved pdfs from opening in Opera browser by default

  • I used the search function to try to find this answer, but couldn't so am entering a post.

    I downloaded the Opera browser a couple weeks ago, and I like it. It seems to run faster than IE or Firefox, and there are many options to customize it, and I really like that it blocks ads/pop ups. In Chrome I chose 'block popups' but there are still a ton.

    In any event, my problem is that when I download a pdf file, saved to computer, when I want to view it my computer defaults to opening the Opera web browser. It also changed all pdf icons to Opera icon. I have been using Foxit Phantom Business PDF and keep setting that to my default program, but it is not working - Opera seems to override my "default" choice every time. Argh.

    It wastes battery and system resources to open a browser every time I want to view a pdf. I have been using the right-click menu (Windows 10) to open pdfs manually but it is more hassle.

    I can't seem to figure out how to stop the auto-launch of Opera browser for all downloaded or saved pdf files. Does anyone have any tips, or options to stop this? Thank you.

  • You haven't said what operating system. Assuming it's Win 10, go to Settings (Win-I) / System / Default apps. At the bottom click "Default Apps by File Type. Wait a few seconds the find .pdf in the list. Set your favorite viewer there.