Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How can I disable the ctrl-space keyboard shortcut?

  • Hi everyone.

    Just re-installed OS for my laptop and switched from Chrome to Opera 18, which IMO, acts way better in low-memory environment and still as fast as Chrome (Great job, Opera team!)

    But there is several things really annoys me. The first one is this ctrl-space keyboard shortcut.
    I'm a Chinese user, I use ctrl-space as keyboard shortcut to switch between IME & non-IME modes.
    For some reason I don't know, my IME doesn't work in Opera's address bar. That's fine, since I don't use IME to type URL anyway (but I still do hope you can fix this. You can find the IME I'm using at http://pinyin.sogou.com/ of course it's a Chinese IME) So I have to switch to non-IME, type URL, switch back again, which is basically what I do when I need to type URL in a browser over these years.

    The problem is: opera always takes me directly back to speed dial page while I finished typing URL, hit enter, then hit ctrl-space (very quick, like I said I've been doing this for years it's kind of a habit) to switch to IME mode. At first I thought I had some connection problem, then I figured out it's opera using ctrl-space as it's own keyboard shortcut.

    So, I don't need this ctrl-space to speed dial shortcut anyway (I would rather just ctrl-T to open a new tab) Is there anything I can do to permanently disable this annoying shortcut?

    Thanks in advance.

  • Not yet, AFAIK, but they said they would tell is how.

    I am still waiting to find out.

Locked