Can not find the "Outgoing Log File=" string

  • OK, I found the following at

    http://www.opera.com/help/tutorials/mail/advanced/#outgoing

    To activate logging for outgoing mail, follow the steps below:

    For the account in question, find the line marked with "Outgoing Log File=".
    Enter a path and filename, for example: Outgoing Log File=C:\outgoing-log.txt.
    Save the file and start Opera.
    Try to send mail.

    My email account for this provider requires TLS to send messages. I can receive with no problem, but can not send, and I am getting no error messages as to why.

    So searched on the web for, and found the above. HOWEVER, when I found the ini file for my account (At least I think it is the correct account), there is no "Outgoing Log File=" string, and no "Incoming Log File=" for that matter. I opened the file with a text editor that can search for any of the above with no joy.

    I tried to search this forum using the key words "Incoming Log File=" or "Outgoing Log File=". With quotes and did not get any hits. With out, I get a bunch of hits, but none of them are about my issue, Also tried Mail and Account and got lots of hits, but, again, not what I am looking for.

    Note that I have no trouble trying to modify the file, but nor sure where to add the line...

    Version info:

    About Opera Mail
    Version information
    Version 1.0
    Build 1040
    Platform Win32
    System Windows 7 x64

    I am sorry if this has been asked & answered, but I could not find it...

    Thanks for any help

    McK

  • At some point, a regression popped up where those lines are missing by default. However, you can add them in yourself and they'll work. In accounts.ini, you add them under the section for the account you want to log.

    You can use environment variables in the paths like:

    [Account 1]
    Incoming Log File={Home}Desktop/incoming_log.txt
    

    for example. However, at some point, a bug popped up where those don't work right. So, use absolute paths with no environment variables in them.

  • My email account for this provider requires TLS to send messages. I can receive with no problem, but can not send, and I am getting no error messages as to why.

    With TLS check for the SMTP, use port 465. If that doesn't work, try port 587. Make sure authentication is set to "auto".

    If you have an anti-virus email scanner, turn that email scanner off. Or, try with TLS off on port 587 or 25 if you're going to keep the email scanner on. Then, if configured correctly, the connection should run through the email scanner first, but connect securely to the server on its way out. Or, if you still want TLS on and what to use the email scanner, you might have to accepted a certificate from the anti-virus. If you already did this, try deleting opcert6.dat in the preferences folder while Opera is closed (see help -> about Opera Mail" for the location). That should cause the dialog to pop up again.

    In Internet Options in the control panel, goto the connections tab and then "LAN Settings" and make sure you're not using a proxy if you're not supposed to be.

    Also, check "C:\Windows\System32\drivers\etc\hosts" with a text editor and make sure all lines are commented out or that you just have:

    127.0.0.1 localhost
    ::1 localhost
    

    You don't want to have any invalid hosts names in there or sending can fail.

  • Thanks burnout426,

    OK, The email provider is one of the companies I contract with..

    So they require that I use TLS for both receiving and sending.

    This is what was in the log file...

    ==== Logging started ====
    06/04-2014 09:45:23 SMTP OUT :
    Connecting...
    06/04-2014 09:50:23 SMTP IN :
    Disconnected
    06/04-2014 09:55:23 SMTP OUT :
    Connecting...
    06/04-2014 10:00:23 SMTP IN :
    Disconnected
    06/04-2014 10:02:37 SMTP OUT :
    Connecting...
    06/04-2014 10:07:37 SMTP IN :
    Disconnected

    Here is the ini file, I have removed the personal info, also not sure how to format this to make it easier to read..

    Opera Preferences version 2.1
    ; Do not edit this file while Opera is running
    ; This file is stored in UTF-8 encoding

    [Accounts]
    Version=9
    Next Available Id=2
    Count=1
    Account1=1
    Added 11.60 Upgrade Mail=1
    Headers=Subject,Date,From,Organization,To,Cc,Bcc,Reply-To,Newsgroups,Followup-To,Resent-Date,Resent-From,Resent-To,Resent-Cc,Resent-Bcc,Resent-Reply-To,User-Agent,X-Mailer,Also-Control,Approved,Archive,Article-Names,Article-Updates,Comments,Complaints-To,Content-Disposition,Content-Transfer-Encoding,Content-Type,Control,Distribution,Encrypted,Expires,In-Reply-To,Injector-Info,Keywords,Lines,List-Id,List-Post,Mailing-List,Mail-Copies-To,Message-ID,MIME-Version,Posted-And-Mailed,Received,References,Resent-Message-ID,Resent-Sender,Return-path,See-Also,Sender,Status,Summary,Supersedes,X-Face,X-Priority,Xref,X-Mailing-List

    [Account1]
    Incoming Protocol=POP
    Outgoing Protocol=SMTP
    Charset=iso-8859-15
    Personalization
    Xface
    Temporary=0
    Category=
    Incoming Port=995
    Outgoing Port=587
    Secure Connection In=1
    Secure Connection Out=1
    Secure Authentication=0
    Incoming Authentication Method=31
    Outgoing Authentication Method=31
    Incoming Timeout=60
    Outgoing Timeout=90
    Remove From Server Delay Enabled=0
    Remove From Server Delay=604800
    Remove From Server Only If Marked As Read=0
    Remove From Server Only If Complete Message=1
    Initial Poll Delay=5
    Poll Interval=300
    Max Download Size=0
    Purge Age=-1
    Purge Size=-1
    Download Bodies=1
    Download Attachments=1
    Leave On Server=1
    Server Has Spam Filter=0
    IMAP BODYSTRUCTURE support=1
    IMAP IDLE support=1
    Permanent Delete=1
    Queue Outgoing=0
    Send Queued After Check=0
    Mark Read If Seen=1
    Sound Enabled=0
    Manual Check Enabled=1
    Add Contact When Sending=1
    Show Warning For Empty Subject=1
    Account Name=xxxxxxxxx
    Incoming Servername=xxxxxxxxxxxx
    Incoming Username=xxxxxxxxxx
    Outgoing Servername=xxxxxxxxxxx
    Outgoing Username=xxxxxxxxxxx
    Force Charset=0
    Allow 8Bit Headers=0
    Allow 8Bit Transfer=0
    Allow Incoming QuotedString QP=1
    Prefer HTML Composing=4
    Real Name=xxxxxxxxxx
    Email=xxxxxxxxxx
    Replyto=
    Organization=xxxxxxxx
    Signature File={LargePreferences}mail/signature1.txt
    Sound File=
    Reply=On %:Date:, %f wrote:
    Followup
    Forward=\n\n------- Forwarded message -------\nFrom: %:From:\nTo: %:To:\nCc: %:Cc:\nSubject: %:Subject:\nDate: %:Date:\n
    Linelength=76
    Remove Signature On Reply=1
    Max QuoteDepth On Reply=-1
    Max QuoteDepth On QuickReply=2
    Outgoing Log File=D:\Personal\outgoing log.txt
    Auto CC=
    Auto BCC=
    Signature is HTML=0
    Low bandwidth mode=0
    Fetch Max Lines=100
    Fetch Only Text=0
    Default Direction=0
    Default Store=2

    I am currently using Thunderbird by Mozelle and am not having this problem.

  • I am currently using Thunderbird by Mozelle and am not having this problem.

    What port are you using for the SMTP server in Thunderbird? Does the "connection security" say "SSL/TLS" or "STARTTLS"?

    To find the setting, look for "Outgoing server (SMTP)" at the bottom of "Account Settings". Then, select that SMTP server and click "edit".

    If the port in Thunderbird isn't 465 or 587, that could be why things are working for Opera.

    Do you know if your SMTP server requires you to be logged into POP right before you send? You could click the drop-down next to the check/send button and click "check all" and then hurry up and click send on the message you're composing to see if that works. Opera doesn't support POP before SMTP. But, I don't thing thunderbird does either, but there's a "Get before send" extension for it. Are you using that?

  • To Answer your questions...

    What port are you using for the SMTP server in Thunderbird?

    587 (Same setting in Mail)

    Does the "connection security" say "SSL/TLS" or "STARTTLS"?

    SSL/TLS (Opera has a check box for TLS, and that is selected)

    If the port in Thunderbird isn't 465 or 587, that could be why things are working for Opera.

    Huh? Opera Mail is not working, Thunderbird (T-Bird) IS working. I am trying to get Opera Mail to work, not T-Bird...

    Do you know if your SMTP server requires you to be logged into POP right before you send?

    No I don't know. But again T-Bird is working.

    You could click the drop-down next to the check/send button and click "check all" and then hurry up and click send on the message you're composing to see if that works.

    Will try...

    Opera doesn't support POP before SMTP. But, I don't thing thunderbird does either, but there's a "Get before send" extension for it. Are you using that?

    I have the "get before send" option selected for Opera Mail. I do not see a setting for that in T-Bird. And I have not installed any extensions in either program.

    Again thanks for trying to the help

    McK

  • Try port 465 in Opera instead of 587.

    In Thunderbird, you can set whether you want to use STARTTLS or TLS. But, in Opera you only have an option to turn on TLS and whether Opera uses STARTTLS or TLS depends on what port you use. Port 465 will cause Opera to use TLS. Port 587 will cause Opera to use STARTTLS. If the server wants TLS on port 587 instead of STARTTLS, Opera won't do that (and the server shouldn't be set up like that either).

  • Changing the port to 465 did it. Not sure why the Sys-Admin told me to use 587, but that is what I am using in T-Bird and it is working as well

    Thanks for the help

    McK

  • Not sure why the Sys-Admin told me to use 587

    Port 587 should only support a secure connection and should only support StartTLS. 587 shouldn't support a direct TLS connection. That's what port 465 is for. But, some servers support a direct TLS connection on port 587 anyway (and some servers support insecure connections on port 587 anyway). The reason that works in Thunderbird is that Thunderbird supports that configuration. The reason it doesn't work in Opera is because Opera doesn't support that configuration.

    The sys-admin probably doesn't know that Opera doesn't support a direct TLS connection on 587. But, the admin should have suggested 465 as an alternative. As for whether the admin knows that 587 shouldn't support a direct TLS connection, he might know and just doesn't care as it works fine with most mail clients and a lot of servers do it. Then again, he might not know and can fix things. But, that'd cause some users to have to switch to 465, which may be undesired, especially if it's only to deal with Opera's strictness. Suggesting port 465 as one of the options should be good enough.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.