Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

Opera 41: MAILTO: links won't use system default email application

  • I am running MacOS Sierra 10.12.1 and I don't use web-based email. I use a standalone email client that sends/receives through a SMTP/POP3 server that I host locally.

    When I clicked an email MAILTO: link in Opera 41, it opened up a gmail form. Under Preferences --> Privacy & Security --> Handlers, there was a handler for MAILTO: links to send them to gmail. After deleting that, MAILTO: links did nothing.

    I found the MAILTO: extension and installed that, but it only lets me select web-based email, which is fine for kids and grandparents, but not for me.

    So, how do I get Opera to use an external application (the system default one, specifically) for email?

  • It's been more than two days since I posted that. Does no one have any insight into how to resolve this?

  • I can only say: no problem here! With a similar setting like you (standalone client, POP3, macOS 10.12.1) Opera (41) opens instantly the defined email-client, when clicking a mailto:-link.
    Perhaps you have to refresh your "standard-email-client" in the macOS-preferences or directly in your email-client?

  • Thank you operaoperandi! I went into Mail --> Preferences --> General and found a "Default email reader" of Opera.app. I didn't put that there! I never would. Nor do I remember answering a question when starting Opera that granted it permission to make that change (though I won't swear that it's impossible -- I sometimes read things a bit too quickly).

    I really appreciate your help.

  • My pleasure!

Log in to reply