After update 41.0.2353.46 background tabs loads on startup when delay loading is enabled

  • Yesterday I got the update 41.0.2353.46 and then I reopened Opera after updating all saved tabs from last session started to load. I have the settings for keeping my tabs from last session enabled and delay loading of background tabs enabled. Tried a few times today opening and closing and background tabs load everytime.

    Steps to reproduce: open Opera setting, find show advanced setting and enable it, find continue where I left off and check it, check delay loading of background tabs.
    Open some tabs, close Opera and reopen again.

    Actual result: All tabs starts to load one after one-other.

    Expected result: Only the tab that was selected then Opera was closed should load.

    OS: Windows 10
    Opera version: 41.0.2353.46 --stable

  • Can confirm this, it's really annoying since "Delay loading of background tabs" is one of the best features I haven't found in other Chromium browsers like Vivaldi yet. I really hope that it will be fixed soon.

  • The startup sequence has been seriously redesigned for Opera 41 as described here: https://www.opera.com/blogs/desktop/2016/10/86-percent-faster-opera-41-for-computers/

    Can you please confirm that the setting "Delay loading of background tabs" is not taken into account and loading is the same regardless of the setting state? Thanks.

  • No it's not the same if it's off but background tabs used not to load at all before 41.

    I see that it's just delayed and not loaded when needed (lazy loading) but I think that the new setting "Delay loading of background tabs" should be default (who needs to load all tabs at the same time anyway?) and replace it with "Don't load background tabs until used" instead.

    I have many tabs pinned that I don't need every time when I start Opera so I really liked the old way of loading and speed dial / bookmarks don't replace that.

  • Ok, thanks. Actually, it is a very good idea.

  • To restore the old behavior you need to disable this feature - opera://flags/#extended-lazy-session-loading

  • To restore the old behavior you need to disable this feature - opera://flags/#extended-lazy-session-loading

    Same problem here, and disabling extended-lazy-session-loading fixed it. Thanks!

  • Thanks for the advice, I still think that all Opera users would appreciate the new background loading as default setting and an advanced setting for lazy loading.

  • Ok, thanks. Actually, it is a very good idea.

    @idrin
    Will it be changed again or is the flag the only workaround for now?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.