Flash player error & plug-in path for opera devel - 42.0.2372.0

  • Hello guys, I start this discussion because in the opera devel 42.0.2372.0, I have figure out some problems.

    The flash player does not work

    I did try with flash ver.23.0.0.162 and ver.22.0.0.209; In addition, there is an security issue with flash version 22.0, I intend to upgrade to version 23.x or different version of flash from others.

    I got difficulty in changing plugin path.

    It used to be easy as in documentation "Search with 'General principles of manual installation' Installation of Plug-ins for Opera on Linux ". I suppose to make a new plug-in path for opera instead of using together with google-chrome, but I cannot find documentation talking about this.

  • It used to be easy as in documentation "Search with 'General principles of manual installation' Installation of Plug-ins for Opera on Linux

    That documentation is outdated.

  • Make sure to install the PPAPI Flash player from Adobe.

  • Thank you guys. For all who have this issue. Using Adobe Flash Player Version: 22.0.0.209 gonna help you work around this issue. My solution is to download and override the flash player at
    /opt/google/chrome/PepperFlash/libpepflashplayer.so

    NOTE that it's need to replace libpepflashplayer.so and manifest.json file if you do.

  • Same problem. I'm using opera latest stable version 40.0.2308.81 upon Linux mint 18 64bit, and I cannot find a way to use flash plugin. I've tried all of the known solutions but no one works. The largest problem is I can use the same version of opera with the same version of flash in Mint 17.3 32bit version on another computer.

  • After much tribulation, I finally got Flash Player working in Opera, Opera-Next, and Opera-Beta

    I simply downloaded the version 23.0.0.207 from Adobe (.gz version), extracted the libpepflashplayer.so file and installed it as follows:

    mkdir /usr/lib/PepperFlash

    cp libpepflashplayer.so /usr/lib/PepperFlash/

    restart browsers and it worked.

  • From my experience, ronheron's solution is correct. Just had to also cp the manifest.json into /usr/lib/PepperFlash/ and it worked like a charm.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.