Forces the Unity theme on Xubuntu

  • I have installed today Opera Stable and Developer on Xubuntu 16.04, and both seem to force the Unity theme, leaving a gray background behind the tab bar. Worst of all, when I maximize the window, it leaves me with no window decorations!

  • This is not an issue with Opera, but with your distro's theme. You'll need to find another theme because Opera pulls from whatever is the default theme.

  • This is not an issue with Opera, but with your distro's theme. You'll need to find another theme because Opera pulls from whatever is the default theme.

    It seems you are right, I'll report this against the Greybird theme! The problem with the window decorations disappearing on maximizing remains, though!

  • It's not a bug. In Xfce and Gnome Opera hides the title bar to save space in maximized state. And it's a really clever feature. You can always perform a double-click in the tab bar to unmaximize the window. Also, in maximized state there should be a [X] in the top right corner to close Opera. This is the way Opera should work in every distribution, but unfortunately in Cinnamon or Pantheon for example this doesn't work, so you always have the space wasting not necessary title bar in maximized state.

    Also the grey tab bar background in Xfce is not a bug. It's related to the greybird theme and i find it looks really nice with the contrast to the tabs.

  • The dark background was fixed on Xubuntu Yakkety, and it was due to changes in the latest GTK+. As for the other bug, calling something so badly done as a clever feature doesn't make sense at all. If I want the window decorations hidden, I just go full screen with F11. Double clicking to restore is something many users won't know, and doesn't work when there are tabs enough to cover the whole tab bar. It was something designed specifically for Unity, and should be disable in any other environment.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.