Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Earlier today I was listening to Pandora just fine, now when I try to listen, it comes up with a Message saying "Please ensure you are using the latest Flash Player. If you are unable or do not wish to upgrade your Flash Player, please try a different browser. Please check our Help page for information about troubleshooting Pandora on your browser." I updated the flash player, but it still does the same thing. I went into settings and everything is enabled. I tried it on a different browser and it works just fine. Also MLB.TV doesn't working either, I think it might be a related issue, any suggestions what the problem could be?

  • Is Turbo enabled? Have you tried clearing your cache? Do it work in a private window?

  • I turned on turbo, cleared cache, and tried a private window and it's still not working. It's so strange how it just stopped out of nowhere and I can't figure out what it could be.

  • One more hit: can you please go to Settings > Websites and make sure that the Plugins section has either "Run all plug-in content" or "Detect and run important plug-in content (recommended)" selected? Also, if the "Detect…" is selected, please change to "Run all…" and re-check. Thanks.

  • I went to settings > websites and it was selected on "Detect and run important plug-in content" and tried the other option you suggested, but that didn't work either. I found a forum though on Adobe that someone else was having the same problem as I was that started at the same time mine did also, and someone suggested un-installing the current version of adobe flash player and downloading an older version, and that worked for me . Apparently there is some sort of bug that Adobe needs to fix according to the staff member who wrote on the forum, thank you both though for your help 🙂