Default Browser problem

  • After using Firefox for many moons, I've switched to Opera (again), as it runs one heck of a lot better these days. I have set Opera as my default browser, and to always check that it's the default. But now, my Windows 10 default settings page pops up automatically whenever Opera loads! Even though Windows has Opera listed as the default browser. Opera's settings do not give me any way to stop that unnecessary settings page from loading.

    So it's not resolvable, well it's not the end of the world (I don't think).

  • Been reported more than once.
    For example, here: https://forums.opera.com/topic/16869/default-opera-problem

  • Try this :
    Go to WINDOWS settings
    On system
    click on default programs(left side)
    scroll down and click on " choose default value for the application" sorry I'm french
    let's load and click on opera stable (left side)
    click on 'choose default settings for this application"
    check all BUT NOT
    CRX
    NEX
    PDF (if you want or not)
    FTP
    MAILTO

    click on save at the bottom right

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.