Why does Opera Mail keep ticking the box?

  • Just started using Opera Mail and I like it. But I noticed that when I go into Tools - Preferences - Advanced and untick the box next to Enable Sounds, when I re-open that a few seconds later Opera has reticked that box.

    Why? I don't need or want any Program Sounds. I have all sounds on my system completely shut off, so I'm not hearing any Opera Mail sounds, but why does the program keep reticking that box right after I did just the opposite?

  • It's a known bug. Opera Mail is just Opera 12 with some stuff removed/hidden to make it look like only mail. In doing so, a lot of preference bugs were introduced. And, since Opera Mail was never finished and is no longer being worked on, those bugs won't be fixed.

    It is better to install Opera 12 and use it for just mail. In advanced preferences under "programs", you can add/set http and https to open in the browser of your choice so links in emails open in that browser.

    For Opera Mail though, just ignore that preference and manually edit it in operaprefs.ini while Opera is closed. See "Menu -> help -> about Opera Mail" for the location.

    Just set these to 0:

    Show Notification For New Messages=0
    Show Notification For No New Messages=0
    

    However, there's a specific sound setting on the incoming tab in each mail account's properties. You can uncheck that. If that keeps getting reticked, close down Opera and edit accounts.ini in the mail folder. See about Opera for the location of the mail folder. In accounts.ini under the section for each account will be a sound setting. You want it to look like this:

    Sound Enabled=0
    Sound File=
    

    Buggy Opera Mail won't revert you manual settings as long as you don't change preferences in the UI in that section of preferences again. If you do, you'll have to close down Opera and manually set them again.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.