Internal Communication Error Opera v12.16

  • Hi, this is my first post so apologies if I do something wrong. I left my computer on today with a few tabs open and when I came back to it maybe 2/3 hours later I can't load a page in Opera. I'm running the newest version of the old Opera, if that makes sense. Before the switch to Opera 15 I mean. Every time I try to load a page I get 'Internal Communication Error'. I can load pages on all other browsers and I can load pages on Opera 15 and 12.14 which I downloaded to check. I don't want to work with those however as I lose the ability to stack tabs and in the case of a downgrade I seem to lose all my tabs and Speed Dial choices. I haven't updated my firewall or changed anything on my computer. Opera was working perfectly, I left it a while and I can't do anything now. I've reset the router, turned the computer off etc and nothing has changed. I'm applying for universities at the moment so I have a lot of important pages open that I really need, I'd be very grateful of any advice. I don't really want to switch versions, I just want a fix for this version is anybody has it. I'm sure others must have encountered the same problem. I'm running Windows 7 Home - 64 bit.

    Thanks

  • "Internal Communication Error" is an old unfixed bug. Of course, they won't fix it since Opera browser was abandoned.

  • Is there nothing at all I can do to help though? And where has it come from?!

  • As STNG has mentioned it is an old bug.... I cannot be any help here, as I never encountered it (some things that may be different in my usage wich may have to be mentioned with a few buzz-words i came along during a quick seach: no sleep mode or such in Windows, always the nowadays "portable"-called install (Opera in one directory with a single profile, no files under user accounts)).... but to see if any of the scenarios/work-arounds mentioned in the numerous threads about the topic can be of any assistance to you (to name just one thread: "Internal communication error" in 12.10), just do an advanced search without a date limit to the results for "internal communication error" - good luck!

  • Hi Shandra, I've read through that thread and others but none of the fixes seem to work for me. I've deleted all personal settings, unistalled and reinstalled Opera, gone to old versions, new versions. Nothing has worked. Was there never a fix for this bug at all then?

  • Not to my knowledge - as the bug itself, from all what i read, was not reproducable/invokable towards the developers at that time - as I said, i never encountered it - as I never encountered memory problems/cpu usage or such within my usage of opera.... all of these where problems I read about within the forum, but never/ever suffered from them myself.... My only problems are of no concern here, as they dwell on my PC/Admin behaviour (or true site specific problems).... so only troubleshooting I can give to you right now would be to rename your old install folder <if it is within the windows "installed software" entries, just copy it - rename the copy and uninstall the true-McCoy>, reinstall 12.16 as "USB portable" [not folder name, but choice of install] to some folder and copy over the email/profile folder. Copy IMHO worked always better then "import", but as said I never got this error... so a blank install under some directory, and a later copy of the old profile folder may get you something to work upon - sorry dude, I am still using some .ini entries from V6/V7 times and as long as i - for myself - does not encounter that problem, for such so long I can't offer any solution towards it 😞 [except, maybe - do not use, or disable all extentions - if you have any installed < I alwys said they are evil and ohBeerAh! shoulf have not allowed such :cheers:>]

  • The bug originally was reported early in the 12.x series as an 'internal comm error' whenever the Internet/network connection was broken or perturbed while Opera was running - Opera would appear unable to re-establish proper connections and emitted the error message. It also seemed to occur when systems were emerging from hibernation if Opera had been left running when hibernation kicked in... again, it appeared to be related to an inability of Opera to re-establish network connections within the computer. Other occurrences seemed to involve proxy changes and wi-fi hiccups. Most of these occurrences were blotted out by fixes made early in the 12.1x series, but still, not all of the users seeing the problem were able to gain relief that persisted, even through the last Presto-Opera version (12.16).

    As Shandra has noted, the problem was very tough for the devs to reproduce. Since no further development is going to occur on Presto-engined Opera versions since Opera has converted its new versions to the Blink engine, this bug is almost certainly not going to get healed in the Presto series. I've personally never stumbled onto it with any of my Opera versions up through 12.14, but of course that doesn't relieve your problem. A suggestion, along the lines of Shandra's, would be to freshly install an Opera version into a completely new-named folder (not the default-prompted "opera" folder name... instead, use something like "opera1216") as well as possibly choosing the USB form of installation. By putting Opera into a new-named location, it avoids importing corrupted Opera files or making use of corrupted Opera registry entries that may have been left behind, even by an uninstall of an earlier installation. You would probably be safe then copying over your bookmarks.adr file and possibly a few other strictly-data files from the old folder to the new, but be careful not to carry in any sessions or operaprefs.ini files - they're some of the most likely candidates for conveying corruption from an old to a new install.

    In any case, I suggest trying the 32-bit form of Opera 12.xx since those appear to have had fewer other problems. One final thought would be to down-grade to something like the 11.64 version (installing it as well into a new-named folder)... I recall no reports of the problem back at that point. I hope you can find a successful solution in a timely way...

  • You would probably be safe then copying over your bookmarks.adr file and possibly a few other strictly-data files from the old folder to the new, but be careful not to carry in any sessions or operaprefs.ini files - they're some of the most likely candidates for conveying corruption from an old to a new install.

    Thanks!

    I had a similar problem, and it turned out that there was something wrong with its connection-related settings. Restoring an old backup of operaprefs.ini solved the problem for me.

    (EDIT: Oops, did I accidentally necropost? Sorry - but I can't find a way todelete this.)

  • @nocturnalyl, Not to worry, we've had older necro-posting than this. Plus you have add useful info to the topic anyway.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.