[Solved]Stop Search with Google/Copy bubble when selecting text to edit

  • I think this is a feature in Opera developer 40; at least it is only happening since I updated, but when I swipe to select a bit of text a little grey bubble appears giving me the option to either "Search with Google" or "Copy". Usually, when swiping text on a web page I am filling in a form and wish to just type to change the selected text in a field such as the one I am typing this post in. I can no longer do this, and it is infuriating. Instead I have to backspace to delete the text and then type its replacement. I can't even select the whole text and then delete. Is there a way to change this annoying behaviour?

    I have the following extensions installed, and one of them could be the culprit: Evernote Web Clipper v6.9, LastPass v4.1.2, Pocket v 1.9.19.

  • Hi @boffinboy, yes, you're right, it's new feature introduced in the latest Opera developer (40.0.2280.0), but you can disable it: go to Settings > Browser > User Interface, and deselect the checkbox to the left of "Enable the search popup on selecting text".

  • Hi @boffinboy, yes, you're right, it's new feature introduced in the latest Opera developer (40.0.2280.0), but you can disable it: go to Settings > Browser > User Interface, and deselect the checkbox to the left of "Enable the search popup on selecting text".

    thanks for sharing this, I did find it annoying considering I have a translation addon that also pops up on selection, and it was hidden behind Opera's popup

  • Excellent! Thank you. I also find that if I scroll up or down just a fraction then the popup disappears. I am using a mac with a "magic mouse" so this is easily achieved with a small up-down movement of my finger on the surface of the mouse, but it means that I have to actually think as well as look at the highlighted text on the screen when I might otherwise already be reading and typing the text I intend to use. Thank you for sharing the fix.

  • Whew. This was driving me crazy too.

  • I would suggest not having this happen when selecting text in any form fields...this is the use case this causes the most annoyances (as pointed out, when you are selecting text in a form field, its almost always because you want to edit/delete it, not copy or search).

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.