Can't Launch Opera With Runas

  • Hello All,

    I am new to Opera and trying it out on Windows XP sp3. I always like to run a browser as a limited user to prevent websites from installing software as I browse, so I installed Opera 36 with the option "for all users". The Opera works if I log into Windows XP as the limited user and run a simple batch file (jk.bat) with this command in it:

    e:\opera\launcher.exe --user-data-dir=e:\OperaStable

    where e:\OperaStable is a copy from c:\Documents and Settings...Opera Stable which I recursively unprotected (this is not a permissions problem)

    However, if I am logged in as the admin user and I run ----> C:\WINDOWS\system32\runas.exe /user:joek_local e:\opera\jk.bat
    it does not work and everythings hangs. The browser comes up but nothing is responsive. Even if I runas with the admin user with /user:joek it still does not work. It refuses to work from the runas command...

    Firefox never gave me a problem launching this way:
    C:\WINDOWS\system32\runas.exe /user:joek_local E:\firefox43\firefox.exe

    I like to log into Windows XP as the admin and launch browsers as a local limited user with runas. This has worked well for me in preventing unwanted software installs...

    Does anyone have any insight as to why this is not working?

    Any help is greatly appreciated...

    Joe

  • May be something specific to launcher.exe. You could try targeting the opera.exe in the versioned folder next to launcher.exe. Of course, if that does work, you'll have to fix the path in jk.bat to point to the new opera.exe every time Opera is updated. Or, you'd have to do some stuff in jk.bat to determine the latest versioned folder path and target that opera.exe.

  • No, didn't work. Even if I right-click on the opera.exe from explorer and choose Run As... it dosen't work.
    I can't find any error log either.

    Does anyone know if opera writes to a text log file?

  • This is a Chromium issue that also affects Windows 7 (but not Windows 8?). Adding the command line argument --allow-no-sandbox-job fixes the issue, at least under Windows 7. However, there may be some security cost to doing so; see http://peter.sh/experiments/chromium-command-line-switches/. Solution obtained from https://productforums.google.com/forum/#!topic/chrome/skfp2nyNh4o. It would be nice if they removed the need for this workaround.

    Another proposed solution (https://forums.opera.com/topic/1799/run-as-different-user) is to use the --no-sandbox argument, but that option would seem to entail a greater loss in security than --allow-no-sandbox-job.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.