Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera ignores /etc/hosts

  • Hi, I am attempting to block myself from visiting a bunch of sites so I can actually get some work done this weekend by editing /etc/hosts

    For some reason Opera is not respecting the rules I have set. (Chrome and Firefox and Safari are all playing nice)

    If you go to chrome://net-internals/#dns it says "Internal DNS client enabled: true" which I'm guessing is the culprit. How do I turn this off?

  • My configuration says

    Internal DNS client enabled: false
    

    but I've hot the same problem. Opera ignores /etc/hosts configuration. I started experiencing this today, after upgrade to Opera 40

    UPDATE: Enabling and disabling Opera Turbo helped.