opera mail cannot be default email client in Windows 10?

  • I'm using Opera Mail 1.0 1044 in Windows 10. Under preferences > general I checked the box to make Opera Mail my default email client. But Windows 10 won't let me select Opera Mail in the default programs app or in the send-to menu of file explorer.

    Has anyone had the same problem or can anyone offer guidance? Thanks.

    Frank

  • Try the zip file at the bottom of https://www.reddit.com/r/operabrowser/wiki/m2tips/default_programs as admin. Then, restart. Then, set it as the default client as admin first. Then do it set it in default programs for your user account.

    It sets up totally different registry entries that do not interfere with Opera's, giving you a new option in default programs for Opera Mail that should work.

    Btw, the checkbox is broken in the settings of Opera mail. Checking it will make things worse and unset Opera Mail as the default client.

  • Thank you for the solution, burnout. The ZIP and instructions work (I just had to Google how to merge a registry file). I am now just wondering if I am supposed to uninstall my earlier version of Opera Mail? I now have "Opera Mail" in my Start Menu as well as the new "Opera Mail 1.0 1044" from this new install that places the operamail.exe in the correct folder (C:\Program Files (x86)\Opera Mail)...or will this delete my locally saved data/email messages?

  • You should just be able to right-click on the icon you don't want and choose "unpin from start".

    I wouldn't uninstall anything though through settings -> system -> apps and features or through control panel -> programs and features. I'd just delete any start menu items you don't want and any program file folders you don't want. I wouldn't worry about any Opera registry entries that aren't needed.

    That way, you don't accidentally remove anything important.

  • Ah, gotcha. Thank you for the quick reply. I do see that the new installation is using the same location for storing the emails/data (in C:\Users\XXX\AppData\Local\Opera Mail\Opera Mail\mail) so I assume all my settings are there as well because nothing has changed in my customized Opera Mail setup. I guess it's just opening the application from the new .exe file location.

  • FYI: I had to right-click on the icon (in the 'All Apps' menu) and select "Open File Location". In that folder I had to delete the shortcut to the old operamail.exe to have it be removed from the 'All Apps' menu.

  • Hi,

    I have the same problem, is this working out of the box for anyone? What is the official comment from Oera on this? This is basic functionality and should work having to fiddle with register settings or patches. If this is a general problem still present after what must be more than a year I guess it shows how much effort Opera is putting into this program...

    My Opera Mail version is reported as
    Versjon: 1.0
    Versjonssteg: 1044
    Plattform: Win32
    System: Windows 8

    However I am using 64-bit version Windows 10. Not sure if that could create some problems?

  • Opera Mail is just Opera 12 with some browser stuff hidden to make it act like just a mail client. However, Opera Mail was never finished and the default client handling was never finished. Opera Mail was discontinued years ago.

    Just use Opera 12 (where mail association works) and use it only for mail. On the programs tab in advanced preferences in Opera, add/set http and https to open in the default browser so clicking on links in emails opens them in the default browser. Opera 12 was discontinued a while ago too though.

    ftp://ftp.opera.com/pub/opera/win/1218/int/

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.