Opera Mail fails to load omailbase.dat is corrupted

  • Hi,
    My Opera Mail has been running as a portableapps on a usb key. Now suddenly I get the message "omailbase.dat" failed to load during initialisation. Since my backup version gives the same error, I have a problem. Does some know what I could do ?

  • Is omailbase.dat in "profile/mail"? Is the size more than 0 bytes?

    Edit operaprefs.ini and make sure there's no "Mail Root Directory" setting under [Mail]. You can try renaming operaprefs.ini so that Opera Mail creates a new one.

    In operaprefs_default.ini, make sure Mutli User=0 is still present under [System].

    Make sure none of the files are set to read only.

    You might want to copy all the files from the USB stick to your computer and reformat the usb. And, run chkdsk on the usb key.

    Make sure accounts.ini is still present in the "mail" folder.

    You could reinstall Opera Mail (after backing up the files on the stick again). Download the installer, launch it, click "options", set the "install path" to "drive:\Opera Mail", set "install for" to "Standalone Installation (USB)" and install. Then, close Opera Mail. Then, put your "mail" folder in "drive:\Opera Mail\profile" replacing the existing one. Then, replace the existing contacts.adr and wand.dat with the backups you just made.

    Unless omailbase.dat is really messed up, some/all of that should fix things.

    (I'm not sure how the portableapps version loads Opera mail. But, if it does it with a batch file etc., you don't need that if you do the standalone installation way and load operamail.exe directly.)

  • Thank you very much for these usefull guidelines. I managed to fix the installation with your help. :coffee:

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.