[Solved]How to add protocol in opera 34

  • When I try to open a magnet link from The Pirate Bay, Opera says that it can't recognize that protocol (Opera was unable to open the link since no application associated with magnet protocol was found), how to set it up?

  • You have to associate it in Windows. Opera uses Windows' file accusations for such things. It doesn't have its own for things it does not open inside itself.

  • If the magnet protocol is associated with a program and it still doesn't work. while Opera is closed, edit the "Local State" file in the roaming profile directory and add 'magnet' to the protocol_handler list. Just search for "mailto" to find it and add a new entry for magnet.

    A while ago, mailto wasn't in there by default and that's what I had to do to get mailto links to be passed to the associated handler.

  • This if full "Local State" file and there in no protocol_handler list.
    {"browser":{"advanced_settings_enabled":true,"hung_plugin_detect_freq":2000,"plugin_message_response_timeout":25000},"hardware_acceleration_mode_previous":true,"icon_version":"7cd526b20c1410a5a88de2ca81bde4b84592dc51","intl":{"app_locale":"en-GB"},"last_version":[34,0,2036,42,0],"location":{"country":"ie","country_from_server":"IE","timestamp":"1461856946600000000"},"partner_content":{"version":{"default":6}},"password_manager":{"os_password_blank":true,"os_password_last_changed":"13095039510156763"},"protocol_handler":{"excluded_schemes":{"afp":true,"data":true,"disk":true,"disks":true,"file":true,"hcp":true,"javascript":true,"mailto":false,"ms-help":true,"ms-windows-store":false,"news":false,"nntp":true,"shell":true,"snews":false,"vbscript":true,"view-source":true,"vnd":{"ms":{"radio":true}}}},"shutdown":{"num_processes":5,"num_processes_slow":2,"performed":true,"type":2},"siteprefs":{"version":"1448630971"},"task_manager":{"column_visibility":{"IDS_TASK_MANAGER_CPU_COLUMN":true,"IDS_TASK_MANAGER_GDI_HANDLES_COLUMN":false,"IDS_TASK_MANAGER_JAVASCRIPT_MEMORY_ALLOCATED_COLUMN":false,"IDS_TASK_MANAGER_NET_COLUMN":true,"IDS_TASK_MANAGER_PHYSICAL_MEM_COLUMN":true,"IDS_TASK_MANAGER_PRIVATE_MEM_COLUMN":false,"IDS_TASK_MANAGER_PROCESS_ID_COLUMN":true,"IDS_TASK_MANAGER_PROFILE_NAME_COLUMN":false,"IDS_TASK_MANAGER_SHARED_MEM_COLUMN":false,"IDS_TASK_MANAGER_SQLITE_MEMORY_USED_COLUMN":false,"IDS_TASK_MANAGER_TASK_COLUMN":true,"IDS_TASK_MANAGER_USER_HANDLES_COLUMN":false,"IDS_TASK_MANAGER_VIDEO_MEMORY_COLUMN":false,"IDS_TASK_MANAGER_WEBCORE_CSS_CACHE_COLUMN":false,"IDS_TASK_MANAGER_WEBCORE_IMAGE_CACHE_COLUMN":false,"IDS_TASK_MANAGER_WEBCORE_SCRIPTS_CACHE_COLUMN":false,"sort_column_id":""},"window_placement":{"height":309,"left":445,"maximized":false,"top":209,"width":476}},"update":{"components":{"next_check_interval":"28800"}}}

  • I can see it in your post. It's "protocol_handler" in the file (you have to escape the _ in your post with a \ or indent the line by 4 spaces if you want to show it properly in your post). Just do this. After:

    "mailto":false
    

    add

    , "magnet":false
    

    There will still be a comma before "ms-help" when you're done.

    When Opera starts up, you might want to double-check that it's not removing the entry you added or changing it to true.

    Also, look here.

  • Thanks burnout426, it didn't help with PirateBay but KickAss Torents works fine. At least something.

  • You can try setting magnet to true instead of false. I'd think that'd make it not work. But, give it a shot if you want and switch it back if it doesn't help. You could also reinstall your torrent client and reassociate magnet links.

    Does Kickass Torrents even use magnet links? I didn't see any in their search results. I see Pirate Bay does. What torrent client are you using?

  • I switched to different client and now everything works perfect. Thanks burnout426.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.