Opera 33において拡張機能と同期のボタンが表示されない

  • Opera ver33においてプライベートモードとして起動したときのみ、右上のツールバー(?)にWOTやuBlock等の拡張機能や
    同期のボタンが表示されません。
    非プライベートモード(以下、普通)に起動した場合は上述のボタンが表示されます。
    普通のウィンドウの左上の「Operaボタン」→「新しいプライベートウィンドウ(I)」と起動したプライベートモードの
    ウィンドウには普通のウィンドウと同じく拡張機能や同期のボタンは表示されます。
    Opera付属のタスクマネージャやブラウジング時の動作から拡張機能が動作していることは確認できております。

    以前のver32のときに自動アップデートでver33にならなかったので最新版のインストーラをダウンロードし上書きインストール
    する形でver33へアップデートしました。 そのときにボタンが表示されない状態だったのでプロファイルごとOperaを
    アンインストールし、OS再起動後再インストールしたのですがプライベートモードのみ拡張機能と同期のボタンが表示されません。

    ver32のときには"最新のver33がリリースされているにも拘らずアップデートしない"、"PPAPIだけしかインストールされていないのに
    PPAPIを認識しない"、"拡張機能のアップデートをかけてもアップデートしない"という不具合がありましたが、ボタンに関わる
    不具合はありませんでした。

    これはver33からの仕様なのでしょうか?
    解決策、そのほかチェックすべき点が御座いましたら、ご教授お願いします。

    OS: Windows 7 64bit SP1 Home Premium
    Opera: 33.0.1990.58

  • Opera をプライベートモードで起動と言うことですが、コマンドラインオプションか何かで指定したものでしょうか。よければ教えてください。

    拡張機能の管理にて、「プライベートモードで許可する」を有効にしていないと、プライベートモードでは表示されないと思います。
    また、手元の環境で、Opera ボタンよりプライベートモードを起動してみましたが、通常時は表示される同期ボタンは表示されないので仕様なのかなと思います。
    (前のバージョンをインストールして比較まではしていませんが)

  • yasu0796様

    コメントありがとうございます。
    [拡張機能の管理]の[プライベートモードで許可する]についてですが、全ての拡張機能の項目にチェックを入れております。こちらは以前のver32やそれ以前からチェックしておりました。 こちらの記入漏れでございました。

    プライベートモード起動時の引数についてですが、以下のとおりです。

    手順1:[スタート]→Opera→「新しいプライベートウィンドウ(I)」をクリック。
    opera.exe "C:\Program Files(x86)\Opera\33.0.1990.58_0\opera.exe" -private --ran-launcher
    launcher.exe "C:\Program Files(x86)\Opera\launcher.exe" -private
    Opera本体 "C:\Program Files(x86)\Opera\33.0.1990.58_0\opera.exe" -private --ran-launcher

    拡張機能 "C:\Program Files (x86)\Opera\33.0.1990.58_0\opera.exe" --type=renderer --alt-high-dpi-setting=96 --system-dpi-setting=96 --disable-direct-npapi-requests --disable-win32k-renderer-lockdown --lang=ja --extension-process --enable-webrtc-hw-h264-encoding --disable-client-side-phishing-detection --with-feature:installer-experiment-test=off --with-feature:installer-ui-stats=on --with-feature:installer-hide-from-program-and-features=off --crash-reporter-pid=5148 --enable-proprietary-codecs-support-for-web-audio-api --device-scale-factor=1 --enable-delegated-renderer --num-raster-threads=2 --content-image-texture-target=3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553 --video-image-texture-target=3553 --channel="6680.4.1246756692\307395778" /prefetch:673131151

    手順2:[スタート]→Opera→「新しいウィンドウ(N)」をクリック。
    Opera本体 "C:\Program Files (x86)\Opera\33.0.1990.58_0\opera.exe" --new-window --ran-launcher

    拡張機能   "C:\Program Files (x86)\Opera\33.0.1990.58_0\opera.exe" --type=renderer --alt-high-dpi-setting=96
    --system-dpi-setting=96 --disable-direct-npapi-requests --disable-win32k-renderer-lockdown --lang=ja --extension-process --enable-webrtc-hw-h264-encoding --disable-client-side-phishing-detection --with-feature:installer-experiment-test=off --with-feature:installer-ui-stats=on --with-feature:installer-hide-from-program-and-features=off --crash-reporter-pid=6892 --enable-proprietary-codecs-support-for-web-audio-api --device-scale-factor=1 --enable-delegated-renderer --num-raster-threads=2 --content-image-texture-target=3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553 --video-image-texture-target=3553 --channel="6884.2.2139756151\1313519510" /prefetch:673131151

    System Explorerのログより以前の32.0.1948.69_1のプライベートモードの引数を確認しましたところ、引数は今回と同じでした。

    このコメントの取り消しができなかったので情報不足ですがこのまま投稿します。
    引き続き調査し、また投稿させていたします。

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.