Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera forces me to "click to play" all content even though this is not switched on in settings

  • Essentially, my problem is this:
    In my browser settings I have it set to automatically run all plugin-dependent content, and yet still wherever this type of content appears it makes me click on it to run it. This has become very annoying very fast. Can someone provide a fix please? Thank you.

  • Turn off Opera Turbo. You will find it in the Opera menu near the bottom. Make sure there is not a check-mark next to it.