Opera 31.0 on Linux Mint - Many Videos on YouTube not playing at all

  • Hi, i'm using Opera 31.0 on Linux Mint 17.2 Cinnamon x64, installed from the software center.

    It's nice to see 60fps videos working on Youtube in Opera compared to Firefox which still doesn't support this feature. However the majority of YouTube Videos (especially older) do not play in Opera. I always get the message "An error occured. Please try again later".

    In Contrast every Youtube Video works in Firefox, with and without flash. Opera seems not to support flash on Linux. It is a little bit annoying if you type in some keywords in the searchbar and almost every video won't play.

    Version: 31.0.1889.174
    Update-Stream: Stable
    Operating System: Ubuntu 14.04.2 LTS (x86_64; X-Cinnamon)

    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36 OPR/31.0.1889.174

    Please help me, I would love to continue using Opera since it has a slick and clean UI.

    Thanks guys

  • Sorry for the double post, I don't know how to edit my post. This problem seems to be very random because some videos work from a specific channel and others don't. I see not pattern. Maybe it is related to some A/V codecs?

  • If you are running version 31, I had to install Pepperflash. You should be able to install it through synaptic package manager. I think it is listed as chromium pepperflash. However. If you do npt have the latest release of Opera 33 I would update to it. I have no problems with Youtube. I hope this is what your looking for.

  • thanks for your reply, roleen0317. pepperflash didn't fix my problem unfortunately. i don't know how to update to opera 33.

    I tried sudo apt-get update, but i'm still on 31

  • Go to Opera.com and Download the Installer then Install it, It will automatically replace old files with the new one and you will be upgraded to Opera 33.

    Hope this will help.

    Regards
    Chad Taylor
    http://www.AceHomeAZ.com/

  • I had the same problem with some videos playing with Opera 31, 32 and 33 and some videos didn't. This thread solved my problem: https://forums.opera.com/topic/12193/how-to-fix-video-playback-problems-with-opera-32-on-linux-tutorial/6
    Now all videos play with Opera 33.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.