Opera Mail - Showing duplicate emails in Main Inbox for gmail account.

  • I have 5 email accounts connected to my Opera Mail client. If I go to All Messages > Received (my preferred view), all emails received for the gmail account show duplicates. However, if I go to the gmail account > INBOX it only shows one email just like when logged in to gmail.

    Any idea why in the main All Messages Received inbox I would be seeing two emails for 1 gmail account even though when you go directly to the inbox there is only 1? It started doing this back on May 4th FYI.

    Thanks

  • Open "All Messages/Received" and click the "settings for this view" icon on the message list toolbar. Make sure "show hidden" is unchecked". There's a "show duplicates" there too, but in this case, you want to uncheck "show hidden" so the copy from "Inbox" (and the copies from other *Gmail* labels) don't show. The only one that should show in "All Messages/Received" is the copy from "[Gmail]/All Mail".

    If unchecking "Show hidden" doesn't help, that most likely means the flags in index.ini in the "mail" folder for the "Inbox" IMAP folder (and any Gmail Label IMAP folders) are not set right. As in, the "hide from other" bit isn't set for those folders.

    Now, if this is with sent messages only, you have to create an Opera label with a a From rule that matches the account. Then, you need to set the label to "hide these messages from other views" in the label's properties. Then, as long as "Show hidden" is unchcked, you should see extra copies of sent messages.

    This stuff is only related to Gmail IMAP as Gmail uses a separate copy of a message for each label the message is in (Inbox is a label). The copy in [Gmail]/All Mail that "All Messages/Received" shows is the original copy.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.