Can't upgrade to 30.0.1835.88

  • I'm running Opera 30.0.1835.59 on Ubuntu precise (12.04.5 LTS) (x86_64; GNOME).
    It's upgraded itself for months using Opera's repository

    deb http://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
    

    Now it suddenly fails. This is the error message I see if I try to upgrade from command line

    $ sudo apt-get install opera-stable
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     opera-stable : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
                    Depends: libglib2.0-0 (>= 2.37.3) but 2.32.4-0ubuntu1 is to be installed
                    Depends: libharfbuzz0b (>= 0.9.11) but it is not installable
                    Depends: libnss3 (>= 2:3.15) but 3.17.4-0ubuntu0.12.04.1 is to be installed
                    Depends: libpango-1.0-0 (>= 1.14.0) but it is not installable
                    Depends: libpangocairo-1.0-0 (>= 1.14.0) but it is not installable
                    Recommends: pepperflashplugin-nonfree but it is not installable
    E: Unable to correct problems, you have held broken packages.
    

    It seems that there are new dependencies and a mix of older and newer required versions.

    Notice that I have installed these versions of those non installable libs (output of dpkg -l)

    ii  libpango1.0-0      1.30.0-0ubuntu3.1
    ii  libharfbuzz0a      0.9.19-1~precise1~test1
    

    There are no candidates for installing libpangocairo.

    I had no problems installing Chrome 43.0.2357.132 and Chromium 37.0.2062.120 (Developer Build 281580) which should use the same engine of Opera.

    Did anything change in the build process for the binary distributed through the repository?

  • Hi @pmontrasio! Yes, this is due to a change in the build process, where the build environment was updated to Ubuntu 14.04.

    It'll be reverted to the previous dependencies as soon as the next Stable version of Opera is released, and this should be very soon. Sorry for the inconvenience :(.

    If you want a newer version of Opera to use in the mean time, you could try using one of the Beta or Developer bleeding-edge versions from http://blogs.opera.com/desktop/. These will run with a separate profile, so they don't affect your main installation of Opera.

  • Thanks @avl for the quick reply. I'll stay with the old version until the new one is released, it's not a big problem now that I know the cause.

  • @pmontrasio this should now be fixed with the newest stable release.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.