Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[DNA-17527] password manager troubles

  • Hi all,

    I have upgraded to the latest stable build of Opera (v20) yesterday. So far so good except the password manager.

    I have noticed that two sites which worked fine in the previous version don't work, I mean login credentials are lost even if these sites have stored their credentials in the password manager. It's silly.

    I have also noticed that now when I want to see a password in the manager the administrator confirmation is required. I don't know if it is a bug or intentional security improvement of the stored passwords. Upon confirmation of administrator login I can see passwords. However after that I cannot open any site in Opera, in fact Opera gets stuck. I have to restart Opera to get it back to work. It's definitely a bug and fully reproducible on my Vista Business 32 system.

    A fix urgently needed.

    Thanks & regards.

  • I also met with this problem

  • The anew password confirmation is a new security feature.
    Did you report that bug?

  • The anew password confirmation is a new security feature.
    Did you report that bug?

    Done!

  • Perfect, thanks πŸ™‚

  • Hi, I'm looking into the issue but I can't reproduce it. I'm using Windows 7, so not sure if it's vista only or something else. Have anyone experienced it on another platform than winVista?

  • Upadate: I'm not able to reproduce it in windows vista either

  • Based on your comment I tried it today again and unfortunately the problem persists. Fully reproducible on my Vista machine.

  • For me the same problem as pe73 under Win7 64bit 😞

  • @pe73: Thanks. I updated your post's headline πŸ˜‰

  • @pe73: Thanks. I updated your post's headline πŸ˜‰

    You're welcome πŸ™‚ Hope it gets resolved soon.

  • Updated to 20.0.1387.77 and the problem still persists. Confirmed by the change log that the issue has not been addressed yet 😞

    • Update chromium to 1750.149.
    • DNA-16648 Adblock not working properly when opening pages in new tabs
    • DNA-17548 Crash on startup in >extensions::OneShotEvent
    • DNA-17556 download callout items won’t open
    • DNA-17722 [Windows] Tone down mixed content graphics
  • Another stable update and no fix yet 😞 I wonder if they are ever going to resolve this bug. I am getting more and more fed up of Opera ... Why I wasted my time to report this bug when developers don't bother to fix it. A shame to speak ..

  • This bug got closed since it's not reproducible.
    Are you able to reproduce this with a clean installation?

  • What do you mean by a clean installation?

    "... closed since it's not reproducible."
    Firstly, it would be nice, in case something got closed, to update a thread accordingly.
    Secondly, 3 users reported the issue in this thread. So this issue isn't being observed exclusively on my machine. Please put more effort to reproduce and resolve it.

  • What do you mean by a clean installation?

    install Opera as a USB-installation and try to reproduce it without changing any settings / installing extensions /...

    What about your user account? Are you admin? Which credentials do you enter to access your PWs?

  • OK, thanks. Unfortunately I am short of time now to try a USB installation. Maybe later.

    I have only admin account, so I am admin. To see passwords an admin account login pops up and I have to fill password of my admin account.

  • Opera 22 finally brought a resolution. No more problems with the password manager described in this thread. You can mark this DNA as resolved.

Locked