CAPS-LOCK no longer works as CTRL

  • I have remapped CAPS-LOCK to CTRL with the help of the Gnome Tweak Tool (running Ubuntu 15.04). Up until Opera 29 everything worked fine, however, in the latest Opera (30.0.1835.59) I can no longer cycle tabs with (SHIFT-)-CAPS-LOCK-TAB. This key combination brings up the tab list and a preview window, however when I release CAPS-LOCK nothing happens. I have to press CTRL to activate the selected tab.

    CTRL-TAB works just as before. Also, in every other application CAPS-LOCK is properly recognized as CTRL.

  • Hmm, this probably has to do with the implementation of customizable keyboard shortcuts, a feature that was new in Opera 29 and then changed in Opera 30.

    One thing you could try to do is to assign caps-lock+tab yourself to tab cycling, by going to Settings -> Configure Shortcuts.

  • "Unfortunately" CAPS-LOCK is recognized as CTRL when I configure the shortcut...

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.