:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

M2 Mail and TLS 1.2 - is this really working in IMAP?

  • 12.17 M2 Mail
    How can I verify that M2 Mail can make a TLS 1.2 connection when collecting mail by IMAP?

    Let's use gmail as an example. I can visit the gmail website in the browser and see that 12.17 has a TLS 1.2 connection, but when I use IMAP to retrieve mail and only the "Enable TLS 1.2" box is checked under Security, the @ icon on the mail account bar never goes away and mail is not received. If I then also check "Enable TLS 1.1" so both 1.1 and 1.2 are enabled, same session, the @ icon disappears and the mail immediately arrives in the Inbox. Enabling all available ciphers makes no difference. I see nothing specific in the mail log on what level of secure connection is established.

    So is M2 or Opera Mail unable to connect any higher than 1.1 when using IMAP?

  • So is M2 or Opera Mail unable to connect any higher than 1.1 when using IMAP?

    I don't if the mail part supports TLS 1.2. But, you might want to find out for sure that the Gmail IMAP server itself supports it (without bugs).

  • [mod edit: Off-topic comment removed. Please read the rules before posting.]

  • [mod edit: Off-topic comment removed. Please read the rules before posting.]

  • I don't if the mail part supports TLS 1.2. But, you might want to find out for sure that the Gmail IMAP server itself supports it

    I get mail from four mail servers, and the SSL Labs test shows them all supporting TLS 1.2 - no distinction between IMAP and POP is given - and none of them will connect if I only enable TLS 1.2. I haven't found a way yet to check what version of TLS actually gets used, but so far I am guessing it is not 1.2

  • Okay.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.