Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

webp instead of jpg

  • Early I could drag image from link like this

    http://i.ytimg.com/vi/6f7pgA0riU8/0.jpg

    to my dekstop. And I always got 0.jpg

    But now I got 0.webp instead of it. What is it?

    There's trouble also with other images from some sites. Only in Opera

  • you probably have turbo mode ON
    When it's ON, data goes trough Opera compression proxy.
    Those webp files are compressed images (and they are pretty good in quality/ size ratio)
    If you want native support in your OS for webp, you should install codec
    https://developers.google.com/speed/webp/docs/webp_codec
    then you can open those images in, for instance, windows photo viewer
    (but many other image viewers doesn't support webp)

    If you download image from right click menu>>save as... (while turbo is ON), opera will download original file, not compressed

    ...
    edit:
    actually, if you drag link to desktop, it will still be a link, not image...
    but everything else stands for webp

  • The expected behavior is Opera to save the original file even with Turbo enabled (e.g. if you save the image with the context menu it'll come in jpeg, dragging to the desktop should yield the same result).

    This is considered a bug. I'll report it.

  • Hey, everyone. I understand how old the thread is, but this is still a problem.

    I want webp disabled completely. It is inexcusable that the browser displays an image as one filetype and forcibly, exclusively downloads it as another. No, Turbo isn't on. Yes, I'm using the newest version of Opera.

    Remove webp entirely, or tell us how to shut it off. None of my operating systems can even open the files and they're even more worthless if I have to put the image into editing software.

    Thanks.

Locked