@burnout426 Yes!! :))) You did it, mr Wonderboy! You solved it. Thanks ever so much! You saved my day. Now I do: cd C:"Program Files"\Opera launcher.exe --disable-web-security --disable-site-isolation-trials --user-data-dir="c:\insecurebrowserdata" And it works again as before. Can't believe how lucky I am :). It's indeed a Chromium issue: I tried Chrome and it's exactly the same thing. I feared that the guys at Opera had disabled this OH so useful feature.