@john2003cpht said in How to force maximize at start every time:

I use the default cinnamon desktop and I have tried launching from the terminal with the same result every time. Thank you all for looking into this.

This seems to be a common issue on Mint / Cinnamon d.m.

Just do a google search for

opera maximize cinnamon desktop

... and you'll see posts going back to 2019. Making changes to the startup icon isn't consistent - there are a couple other shortcuts to try. Some say put a shortcut on the desktop and change it.

Quite a few also change this in Opera:
" In Opera go Menu > Settings.
In the "On startup" section select
"Retain tabs from previous session" (optionally select "Display the start page first" option if you want that). "