Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Unable to Uninstall- No Icon, No Listing Under Apps

  • Hello- I have Opera Mini Browser installed in my Android 4.2.2 HTC Desire 601. The only way I discovered that was when I installed an app that tried to use it as it's default browser to play YouTube, which failed, rendering the app useless. Apparently, it was installed as part of the Virgin Mobile proprietary software group. There is no icon, nor is it listed under settings> apps. It also does not show up on Easy Uninstaller. But it is there- Even Google Play shows that it is installed. I uninstalled(surprisingly) the Virgin Mobile apps "The Feed" and another for "discover apps", which were the only ones visible. That did not eradicate Opera. How do I get rid of it? Anyone have any ideas short of rooting the phone and performing dangerous surgery on it? It is messing up apps I install. HELP!
    Edit: I have tried to contact Virgin- their phone people are of course idiots, and I have not yet heard back in writing from them... I do not expect to get much more than the standard form letter, if they stay true to form. YOU are my only hope!

  • Try this:

    Open Opera Mini.
    Press the Home key to go to the homescreen of the phone.
    Now double-tap or long-press the Home key to display a list of recently used apps.
    Long-press the Opera Mini thumbnail and select to show details.
    What name does it has? You should be able to clear data / disable it there.

  • Thanks for the reply, rafaelluik, but how, exactly, do I open Opera Mini? As I said, I have no Icon, nor listing of it under settings>apps. It is just lurking inside my OS, without any way to access it unless an app, such as Torch Music(which I tried to install) tries to use it. And that app did not give access to Opera's controls- it just showed a grey screen indicating a missing plugin... which rendered Torch Music inoperable. All my previously installed apps use my designated default, which is currently Dolphin Browser(I'm trying it out). The only other app I had that apparently used Opera Mini was the Virgin Mobile "The Feed" app, which I uninstalled, trying to get rid of Mini.
    Can you see my problem? I have no access to it in any way. Not to use, not to change settings, not to uninstall. It is just sitting there, waiting to mess up another app installation that locks onto it thinking it is the default.
    I was hoping there was something, anything, like another app or some routine that could be run to get rid of it. The real irony here is that I really want to USE Opera- The full version, as my main browser! Do you think that If I installed Opera, that it would erase the Mini browser? I'm thinking it would not, and just co-exist beside it like all other android apps do.And the Mini will still be there, untouchable. I guess I may have to give up on Torch(sucks- Torch Music is awesome), and hope it does not mess with any future apps.
    Unless someone has a brilliant idea?

  • There's no sign of it in Settings -> Apps -> All tab? Maybe bearing another name like Virgin Mobile Opera Mini / browser, or internet?

    Can you post a screenshot of what appears when the app tries to use it for YouTube?

  • Nope- not listed in "settings> apps" at all. My phone does not have "settings> apps> all". I took screenshots of Torch Music, My apps list, and the Google Play store showing it installed... but for the life of me, I can't figure out how to upload them to this forum, and the forum does not have a guide or FAQ, as far as I can find. I searched for "post image" "upload image" and "post screenshot" and "upload screenshot" in the search bar on the forum's main page, and it returned nothing but lots of unrelated posts from users.
    Suffice to say, the window inside of Torch Music has no borders, no controls related to a browser. It is just a grayed out window with the classic "missing plugin" symbol. Their is no mention of Opera in any form, not Virgin or otherwise, in my list of apps. That list is short, as this is a new phone.
    I guess I'll give up, and uninstall Torch for about the tenth time now. The Torch tech people are just as baffled as I am, but at least they have been excellent at corresponding with me. Something I can't say about either Virgin or Opera( you of course excluded from my frustration about Opera's "support") Thanks for trying to help, though.

  • Originally posted by samara2894:

    Suffice to say, the window inside of Torch Music has no borders, no controls related to a browser. It is just a grayed out window with the classic "missing plugin" symbol.

    So how do you know it's related to Opera? ...

    Could you please upload the images to and post the links here?

  • I stand corrected- I do have setting> apps> all. I knew I should... but It was off screen, and I can be an idiot sometimes, for a semi- smart person. Still was no Opera. I tried to be tricky and install Opera Mini again, even though Google said it was already installed. And, it DID install. Now I have it listed, and have an Icon. However, Torch is still a no-go. This may not be related to Opera at all. Thanks for your time.

  • You're welcome...

    Just drop by if you discover something that may link this to Opera, but really, it doesn't seem to be.

    This "missing plugin" thing seems related to the absence of Adobe Flash player in your device (or maybe it's disabled somehow) and perhaps you're hitting a YouTube video that isn't available in HTML5. Maybe you could e-mail Torch a screenshot so they can look at it and answer you if their app can use Flash in such cases or something else.