Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera executable not running anymore

  • Hello, I was using Opera normally until a certain day it stopped from working. When I run .opera, nothing happens. The window doesn't show up, no message from the terminal and it is not in the list of ps -A.
    What can be? Thanks for any input

  • You should not run .opera

    Opera is started in shell as opera-stable.

  • Actually it is started as: opera

    The only exception being if you installed opera via the Russian fedora repository, then it is opera-stable.

  • So, no diagnostic tests that I can do? If so, I will be forced to delete the directory and install it again. If that it is the case, is the "bookmarks.adr" the only file related to bookmarks?

  • You are typing the wrong command. Type the right one and report back.

  • ./opera-stable? This doens't exists here

  • ./opera-stable? This doens't exists here

    No! Why do you use ./...? That starts a program in current directory. Do you know how to use the shell?

    Please read:

    Start it with opera-stable

    With these commands

    which opera


    which opera-stable

    you can check wich opera exists in which directory.

  • Start it with opera-stable

    You don't help him when you also keep saying the wrong thing, as already pointed out. 😉 The odds of him using a non-official repack are low and even if he is it would have to be exactly that one, as it is the only repack that renames the main binary.

    If he is suing the official package, he should start it with:


    Nothing else. Don't write a single other thing in the terminal, just that and press enter.

  • When I said it was installed system-wide? I probably should have mentioned it before, but someone shouldn't take it as a certain. Anyway, I won't install it system-wide, so I need alternative ideas

  • Ok I tried to delete the directory and it deleted, except by these files:
    rm: cannot remove opera-12.16-1860.i386.linux/profile/cookies4.dat': Input/output error rm: cannot remove opera-12.16-1860.i386.linux/profile/vlink4.dat': Input/output error
    rm: cannot remove `opera-12.16-1860.i386.linux/profile/widgets/wuid-e7253920-6ee5-11e4-8ad4-c47c57315376/cache/activity.opr': Input/output error

    Any ideas of how I can delete these three remaining files and the containing dir ?

  • Open the folder contain the folders and files you wish to delete as administrator and enter your administrators password (usually by right clicking said folder and selecting 'Open as administrator'). Another (duplicate) window should appear containing the same files and folders, but this one has administrators privileges. You should now be able to delete everything you need to.

    NB: You haven't mentioned which distribution of Linux you are actually using.

  • I don't have that option. Anyway, I tried to delete it through command line using administrators privileges and didn't work. I am reasonably sure this is also the cause for not being able to run Opera

  • May be you have badblocks on your harddrives.

    You should do the following in Shell:

    sudo touch /forcefsck  
    sudo reboot