Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Photobucket issue !?

  • Thanks drewfx, I have changed it, although I hadn't noticed any problems with it the way it was before.
    Hopefully it will fix the problems that lowiepete was apparently having.

  • OK, I'm glad it seems to be working for everyone (knock on wood)! Please post if this is still causing problems.

    I'm going to rewrite the instructions here, with hopefully the correction showing properly by delimiting the asterisks, to make it easier if we want to refer to it in the future.

    Workaround fix for Photobucket embedded images not displaying in 12.17

    I'm not sure if this will cause any problems for other sites, but try this in 12.17:

    • Open the opera:config advanced configuration page.

    • Go to the "Network" section.

    • Under "HTTP Accept" enter the following string:

    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash, */*

    • Hit the save button at the bottom of the Network section.

    • See if Photobucket images are working.

  • Thank you very much drewfx!
    I'm very annoyed by those who always answer "move to the new opera". New Opera has actually nothing of that I'm loving in 12.17.
    I don't know if in the future the "new opera" will reach the "old opera", and I hope yes, but actually the "new opera" is simply "no longer opera".

    Back to your solution, it works in the way you posted as it works (at least to solve my problems) by adding only

    image/gif, image/jpeg

    Again a big THANK YOU!

  • Ehm, I wrote a silly thing... asp websites no longer working without the whole drewfx's string.

    Happy Easter to you all.

  • Yep, drewfx nailed it. BIG thanks!
    In your face Photobucket! In your face Google thieves!
    Opera 12.17 proves again it has invaluable, flexible embedded configuration tools to adapt to any situation.

  • Hi, after searching for a solution I landed here. Initially I fell at the first hurdle when following drewfx's steps. Clicking on the Tools menu, then selecting advance I see options for : Cookies, Password Manager, Blocked Content and so on but no Config option. What am I missing here?

    Keen to try and resolve this one way or another I opened OperaDef6.ini in MS notepad (having made a backup copy first of course) file which contains the following entry:

    [Adv User Prefs]
    HTTP Accept=application/x-shockwave-flash,text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,/;q=0.1

    I cut everything after the equals symbol and pasted the suggested replacement string:
    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash, /

    I saved the text file as .ini, closed and restarted Opera and opened a web page some embedded Photobucket images but the image still fail to load. Can anyone give me some further guidance to help me solve this please?

    Thank you.

  • You need to use the configuration editor page rather than editing the ini file directly.
    Put the original version back (with Opera closed) and then run it again and type "opera:config" (without the quotes) in the address bar and go to it.
    This should open the configuration editor page.
    Expand the "network" section and then find the "HTTP Accept" entry.
    Press the "default" button on the entry, which will probably clear it, and then copy and paste the necessary string into it, and press the save button at the bottom of the section.
    That should do it!
    If there is anything already in the HTTP Accept section, which your ini file seems to imply that there is, I'm not sure why that would be as I'm pretty sure that by default it's empty.
    It is possible that you may lose other functionality if any existing entries are cleared.

  • Thank you very much for taking the time to explain the steps in more detail. Until now, I wasn't aware of this hidden advanced configuration page, so I've learned something new.

    I followed your steps and all is working as expected which is great.

    The "HTTP Accept" field was empty despite the OperaDef6.ini file having this entry filled so clicking Default didn't change anything and it remains unchanged after entering and saving these changes.

    A big thank you to drewfx for posting a working solution to this issue.

    Thanks guys.:)

  • These settings appear to prevent HTTPS web pages from loading coreectly. I'm unable to connect to instagram or my bank when these setting are in place, if I restore the default settings(empty field) and save I can load the aforementioned pages.

    Please see this thread for some more details:

    Could this string be amended to fix this issue please?

    Thank you.

  • I've not noticed any problem here.
    This forum is https for me, and works OK, as does my online banking.
    Can't comment on Instagram as I don't use it.

  • Having just solved this problem for myself (by using wireshark to compare the headers sent by Opera with the headers sent by wget, which does successfully retrieve the image) and then found this thread from googling to see if anyone else had been complaining about it, I feel it is worth posting to clarify a couple of points...

    • It is NOT Opera's fault

    • It IS Photobucket's fault

    Photobucket have misconfigured their servers to react weirdly to the Accept: header. Other sites which do not react weirdly are quite happy with Opera's default Accept: header. It's not Opera doing something wrong, it's Photobucket.

    FWIW I have found that a minimal "Accept: */*" works just fine. Having read this thread I have tested it on twitter (as an example of an HTTPS site) and on Pistonheads, and they both work.

    (Also, to prevent some bug in this forum converting "star slash star" to "weird character like a slash but at a greater inclination, without the stars" it is necessary to insert a backslash before each star.)

  • I was able to get things working as they should by restoring a recent back up of my system drive.

  • Wow, thanks for the string drewfx, and davehawley for pointing to this issue.
    I added the string with the / at the end, and landed up with my forums temporarily unavailable?
    Deleted the / and pasted:

    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash,

    Finally all images seem to work again, even the banner and avatar on my Youtube channel are now visible.
    Have to test it more carefully, but it looks alright.

    With regards

  • Glad it worked for you!
    The */* at the end of the string was added as without it there seemed to be problems with asp pages, although it seemed fine for me without it.
    I added it and everything still seemed to be fine.
    BTW I assume you did include the asterisks before and after the forward slash?
    I only ask because the forum software removes them in posts if you don't put dummy back slashes in front of them! It should be "asterisk-forward slash-asterisk" (without the quotes of course).

  • We have a "Formatting with Markdown" thread in "Forum feedback" - revise it, please. Anybody can do just fine with backticks 😛

  • Thanks joshl, but I don't need to be told that thank you very much!
    I'm well aware of how to use Markdown, I've just never understood why I should have to when every other forum I use you just get what you type!

  • Hi davehawley

    I added indeed first the asterisks and / at the end, but that caused a problem.
    (I noticed they didn't show up in my posting which I couldn't edit)
    Anyway it's still working.

    The "forum temporarily unavailable error" reappeared.
    Maybe one of the plugins causes that problem?
    Disabling all of them restored at least loading.
    The forums load alright with my other browsers including all plugins.
    Have to figure that out.


  • Found another problem
    On the youtube channel, the banner won't show up under certain conditions.
    This is what it should be.

    The funny thing is, that it appears correct in the direct bookmark-link,
    but not if I get to "My channel" in the menulist.

  • Found the latest issue, because "content blocking" was set.

  • Ah, that would have been it!
    Glad you finally sorted it out.

Log in to reply