Opera resets the window size

  • Hi!
    I came from Opera_12 to Opera_dev a few days ago. Everything is OK but I have annoying bug - everytime when Opera is opened it resets window size. Is there any way to fix this?
    I want use Opera in fullscreen mode, but don't want everytime click the fullscreen button.

    LinuxMint 17 x64, Opera_Dev 27.0.1670.0

  • This happens to me as well, pretty annoying but I can tolerate it for now. Would be awesome to get it fixed.

    Arch Linux 64-bit Opera Beta 26.0.1656.8

  • Do you mean maximised or fullscreen (F11)? It should start maxmised. What window manger are you running?

    You can always use a windows matching utility like Devilspie2 as a work around for now.

    Install Devilspie2 and create a file called ~/.config/devilspie2/opera.lua containing the following:

    if (get_window_class()=="Opera developer") then
       maximize();
    end
    

    You can then run Devilspie2 as a daemon (-d) and it will be maxmised.

  • It's not right idea to use third party software to make works Opera as it should by default.

  • The UNIX way is to write small apps that work together. Why not use a windows matching utility for this?

    Opps, I thought I was replying to the thread about removing the titlebar.

    It's not right idea to use third party software to make works Opera as it should by default.

    Yes it should work by default but it works for me, hence why I asked

    What window manger are you running?

    If we know this we can try and fix it for you and others as well

  • My distro is LinuxMint.
    It is from wikipedia: From version 1.2 onward, Cinnamon uses Muffin, a fork of the GNOME 3 window manager Mutter, as its window manager.

  • Do you mean maximised or fullscreen (F11)?

    I talked about maximised.

  • Hi all and thank you for Opera 26. This is by far the best Opera I have used. It is as fast or faster than Chrome and easier to use.

    I am using Opera 26 on Ubuntu 12.04 with a Mate desktop. I cannot make Opera open in a maximized window but have to maximize it each time it starts.

    I have tried the suggestions on these forums but nothing works. It would be helpful if in the beta phase of Opera's development you could address this problem.

    Other than that I have had a smooth transition from Chrome to Opera 26 beta. Please keep up the good work.

    penguin7009

  • Do you mean maximised or fullscreen (F11)?

    I talked about maximised.

    @akarachkinaolga You might want to read your first post again. Here is a quote (with added emphasis):

    I want use Opera in fullscreen mode…

  • I have tried the suggestions on these forums but nothing works.

    The devil's pie suggestion works just fine. Nonetheless it is logged as bug ID DNA-30545

  • Hello, everyone.

    Yesterday I just reported a bug for the window size in Linux version.(DNA-30526)

    I found that if you go to opera://settings and change the settings into "Open the start page" or "Open a specific page or set of pages", then this bug will emerge!

    This problem exists for a long time. Hope it will be fixed in next update!

  • Thanks chenjohnliu!
    It really works 🙂

  • I've had the same issue running Ubuntu 14.04 with Unity. The problem doesn't exist in Opera developer.

  • Kubuntu 14.04
    Yes there is a problem here as well, resizing always reverts, even when forcing size & position in Special Window Settings.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.