Issues running Java 1.7u71 and 1.8u25

  • Hello all,

    I'm reporting that, similarly to what is happening with Windows version apparently, Opera 12.16-1860-x86_64 is having issues running Java applets when using Oracle JRE 1.7u71 or 1.8u25. Downgrading to JRE 1.7u67 solves the problem completely.

    At first I thought this could be an issue with my kernel version (I'm running these tests on Gentoo-amd64), but looking through the forums quickly solved this doubt.

    For what it's worth, I haven't tested on the new beta 25+ versions. The increased installed size and number of dependencies are unacceptable for the purposes I intend to use the browser for.

  • To better illustrate my size/dependency claim:

    ~$ du -sm opera-* | sort -n
    46	    opera-12.16-1860.x86_64.linux
    148	    opera-beta_26.0.1656.8_amd64
    

    That's after decompression, both files. As for dependencies:

    ~$ ldd opera-12.16-1860.x86_64.linux/lib/opera/opera | wc -l
    23
    ~$ ldd opera-beta_26.0.1656.8_amd64/usr/lib/x86_64-linux-gnu/opera-beta/opera-beta | wc -l
    62
  • Dear friends

    I am running beta, and java seems not to work at all, as in chrome. There appears to be no work-around. I have also observed in opera, firefox et al that the newer java does not work.

    thus, running .65 of 1.7 is the only current alternative.

    Please, opera devs, at least let us know whether there is the same situation here as with chromium.

    Best,

    Martin

  • Yes, Java only exists as an NPAPI plug in. As we do not support these, you cannot get Java running.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.