Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Everything is bigger after updating to Opera 24

  • Only because people are misusing this feature to only scale their Desktop icons doesn't make this a bug.

    I'm not using this "feature" AT ALL! There's nothing "scaled" on my fucking Desktop! Are you seriously just playing deaf mute to everyone stating that this is a real issue? Are you seriously saying that it's everyone's fault that this happened? Because your last line sure does sound like that?

    You know what, screw this. Your responses here prove that it's just another case of a biased mod playing deaf mute to criticism on his favorite program.

  • I get that it's annoying. And Opera is evaluating "fixes".
    I just wanted you to realize that other people need this to work exactly as it does now (as you can see in my previous post, people started yelling at Google when they made it smaller again!). Maybe I am not the deaf one in here...

  • Misuse the DPI settings? isn't that meant to make things bigger, and look better on higher resolution? Funny i'm using the windows dpi setting at 125% since i have a fullHD display, else hard to read the text. But it seems i'm misusing it 😃

  • @straydogstrut See?
    sanyigz (no, you are not misusing it. It's supposed to be 125% if you set it to 125%) expects it to get bigger whereas you want it to stay small. That's the issue here. Not dumb Opera devs.
    Again, Opera is evaluating how to please both of you. So please stay patient and try to understand the other 50% that had to suffer until now.

  • Here is how I think it should work:
    --force-device-scale-factor=1 should correspond to DPI 100%
    --force-device-scale-factor=1.25 should correspond to DPI 125%
    etc.
    It should also be possible to change the scale factor from Opera settings. The default could follow the DPI in the OS, but it must be easy for the user to change it.

    With this release of Opera I would use scale factor of 0.8 to get the size the previous Opera version had, but scale factors below 1.0 don't work.

    A quick fix would be to allow a zoom level of 80% (the current options are ...75, 90, 100...). This would still leave the GUI elements big, but at least the pages would look the same as before and as with other browsers with zoom level of 100%. For example in IE the default zoom level is 125% if the DPI is 125%, but it is very easy to change that to 100% to get the desired page size.

    The current version of Opera would show a webpage at 100% zoom level differently from other browsers with the same zoom level. I think this could bug some web developers.

    You have some very nice features in Opera and I would like to continue to use it, but I must be able to view web pages at the size which is the same as 100% zoom of the previous stable Opera version. I think that exposing the scale factor in Opera settings would be a suitable solution for everyone.

  • Despite the fact that some of you perceive me as deaf, stupid and ignorant, I totally agree with what you guys say.
    @jelomaa is totally right here.

    I for one suggested implementing the scaling UI of Telegram (which is an awesome messenger btw; you should give it a spin) which I think is just as simple as powerful. Another approach would be to make Windows' compatibility setting "Disable display scaling on high DPI" work or simply follow Google's approach to disable scaling for 125% altogether. But it's not decided yet what to do.

    For those of you who still think I'm fighting you:
    This feature request (DNA-24328) was filed by me July 31st!
    Again, I just want you to understand that others need it to scale and flaming is not appropriate.

  • I've found really simple solution for users who using windows dpi scaling and struggling with problem "everything looks bigger in Opera 24"

    1. Go to opera settings - web-sites.
    2. Change "Page scaling" from 100% to 75% (if you are using 150% and above dpi scaling in Windows) - or use ctrl + mouse wheel to find your specific percentage - you'll see that is your scale when all pictures on site became clearly visible, not blured.
    3. Adjust the size of your fonts in fonts settings.
    4. Profit!

    Of course it is temporary soluiton, but at least it works - now everything in Opera looks clear and smooth.

  • Not really everything. It really doesn't solve the "problem" (feature?) of the upper bar and the extentions icons becoming obnoxiously big and intruding. Has anybody this problem too? http://i.imgur.com/UKWcwTG.png
    I mainly use opera for loyalty, and because actually I don't dislike the speed dial + stash method.
    But I also enjoyed the nice design.
    Now there is this huge bar, with usless spaces, instead of a more scaled one.
    And no workaround here suggested fixed it.
    Has anybody been succesfull in resizing the UI and not just the text/pages sizes?

  • I've commented about this a couple of times on the developer's blog, going back a version or two. I took some measurements, and as I recall everything is larger than 12.17 by roughly 25%. Since my 1920x1200 screen is already set to 115% dpi, the webkit's enlargement doesn't help. Changing the font size to Small or Very Small in Settings has no effect. Win 8.1

  • As I said earlier, running Opera with a "--alt-high-dpi-setting=96" switch fixes it for me, both the display of web pages and the size of the Opera UI elements.
    I'm on Windows XP at 1920x1080 with "large" (120) DPI setting.
    If this isn't working the cause must be something different to what I'm experiencing.
    Although this annoying "feature" is by design, I've filed a bug report about it too!
    🙂

  • Although this annoying "feature" is by design, I've filed a bug report about it too!

    Yeah, that one was closed as a duplicate of the one I mentioned a few comments above.

  • Ah right, I won't file another one then!
    :lol:

  • Well, I don't bother if you do. I'll tag every one of them as duplicate then; makes my feature request look more demanded 😛

  • "C:\Program Files (x86)\Opera Developer\launcher.exe" --alt-high-dpi-setting=96 - this help for me. Thanks!

  • Well I'm glad it's finally worked for someone other than me!
    🙂

  • @davehawley: Hi Dave, this works also for me on Windows XP/7, and Linux, but I use it for different purpose :whistle: 😉 Anyway thanks for your tip \m/ 🆙

  • That command line switch only works above opera 24, so in current beta and developer release.

  • Well I'm glad it's finally worked for someone other than me!

    Yeah, it works well... if I start the browser with the shortcut. But when i'm clicking on a link in Thunderbird while Opera is closed it opens with the big, bad scaling. We need a real solution.

  • As I said earlier, running Opera with a "--alt-high-dpi-setting=96" switch fixes it for me, both the display of web pages and the size of the Opera UI elements.
    I'm on Windows XP at 1920x1080 with "large" (120) DPI setting.
    If this isn't working the cause must be something different to what I'm experiencing.
    Although this annoying "feature" is by design, I've filed a bug report about it too!

    THANKS A LOT!!!! Man you are made my day. Hell no< you made my month! )))
    OMG I've been struggling for few months and switched to Chrome due to this BUG. And yes christoph142, that's not how it should work. And I don't care how long you are going to explain "this is a feature" in retarded Micrsoft "users don't need Start button" way, because EVERYTHING used to word perfect before Opera 24 release and it f*cked up my Opera browsing experience. While EVERY SINLE App and browser works just fine.
    I really hope developers are going to do something with that, but as I can see Opera 26 for developers has same issue. That's very frustating.
    Sorry for my struggling english 🙂

  • Released Opera 30 and the problem persists, it's so frustrating! This same issue happened with Firefox some versions ago, but it could be fixed doing some tweaking with config to change page content size and installing an add-on to change UI size. Unfortunately this solution is not available with Opera, so the only (partial) fix I've found so far is to set default zoom to 80 %... but, wait, there is no 80 % zoom setting in Opera! Only 90 % or 75 %! Frustating again!

Log in to reply