Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Tab Snoozing happens even with setting disabled

  • @bigskytroutbum Can you let me know which websites snoozed and I will try them on mine (I am not on Facebook or any other 'social' media shites)

    I have 'Snooze inactive tabs to save memory' turned Off
    Also 'Delay loading of background tabs' is turned Off
    The only other setting I think may affect it is Workspaces, which is turned Off as I have never used it

  • @gizmogadget One of them was Yahoo News (https://news.yahoo.com) earlier tonight, which was what prompted me to post. I'm sorry, but I don't clearly remember what the other one was, but it was almost certainly one of these which I keep open continuously:
    https://www.vox.com
    https://www.politico.com
    https://www.npr.org
    https://thebulwark.com

    And, now that I'm concentrating on it, I remember it happening on this very forum page (How's that for irony?), but I can't remember whether that was before or after I installed your extension.

    Hope it helps; please let me know.

  • @bigskytroutbum I have just opened those tabs, will leave them there to see if they snooze.
    Another possibility on why they snoozed is that the extension marks NEW tabs as not to be snoozed, it won't work on tabs that were already open, so you would need to reload opera and all your tabs, or reload the just important ones.

    I got this info from the reviews of the extension: "if you read the extension source code, you'll see it tells Chrome to mark every opened tab as not auto-discardable."

  • @gizmogadget OK, that "new tab/open tab" distinction may very well be dispositive. I go a week or more at a time without powering down or closing the browser. I'll power down tonight and see what happens.

    Again, why does Opera leave it to the users to solve this? I originally reported this on the blog page that announced the new feature (https://blogs.opera.com/desktop/2021/02/opera-74-stable/)
    It would appear that Kornelia doesn't bother to read the comments on any of her blog posts. No one from Opera appears to be reading this forum either.

  • @bigskytroutbum I think they use the blog page for nothing more than announcements - that's if you actually get a post when they release an update, I check every time to see what is new or fixed.
    I just clicked on all of those tabs, none were frozen and didn't refresh, they were still loaded and running OK.

  • @gizmogadget Well, for what it's worth. I recall the snoozes to have happened rather randomly in terms of time, i.e., sometimes after a few hours, sometimes sooner, etc. I'm leaning more toward your "new tab" theory, however, and will test that out forthwith by restarting my system and browser. I hope I haven't wasted a lot of your time with a false alarm as to your extension workaround.

  • @gizmogadget I just restarted the browser and opened each of my usual tabs, which now qualifies them as "New" tabs, right? I'll leave them running overnight and see in the morning whether the Snooze Fairy has paid me a visit. Just realized that I neglected to include https://www.ebay.com in that list of tabs that I keep open continuously. Signing off for tonight; will report in the morning.

    Cheers, as you Brits say.

  • @bigskytroutbum You haven't wasted my time at all. I like digging into computer problems, and although I'm not a coder as such I have been around computers since the 80's and have picked up lots of useful tips and utilities, I still enjoy finding a fix for a problem.

  • @gizmogadget Well, your "new" tabs theory is looking pretty good, GG. As per the above post, I restarted Opera, opened my eight favorite tabs, left them running all night and, some ten hours later, none of them has snoozed. Your workaround extension seems to be getting the job done. I'll check back in if that changes. Thanks again for your time and help.

  • @bigskytroutbum Thanks for your reply, just got back home. Glad it appears to be working so far.

  • @gizmogadgetBad news: Just had two episodes a few minutes apart on this web page https://www.rollingstone.com/culture/culture-news/the-lyman-familys-holy-siege-of-america-235776/ which I'd opened only about a half hour earlier. I discovered the second episode upon returning from ten minutes away from the screen. Neither time did I get the "disable tab snoozing" button option at the top of the screen, and each time the page refreshed easily, but they did nonetheless snooze.

  • @bigskytroutbum I opened your link and left it for 16 mins, clicked on the tab it was ok and not snoozed.

    Not sure if you know this already, you can monitor what the current state of the discards are by typing opera://discards into the address bar - I was watching the Last Active time and Loading State of your site to see if it snoozed, but as it didn't the only info that changed in there was the Last Active time, so no clues there.

    I use uBlock Origin ad blocker, do you use any blockers at all?
    As well as uBlock, I have the built in ad blocker turned off, and block trackers turned on, Block third-party cookies selected (on), and Do Not Track is on.

    Update: I left the tab open while typing this reply, and twice it had not snoozed after another 18 mins + 13 mins.

  • @gizmogadget Thanks. Clearly, I've got something else besides the new tab snoozing bug factoring into this. I run AdBlock Plus, in addition to the on-board Opera ad blocker, Ghostery, and Privacy Badger. Probably a little overkill there, but I've been running all of them for years with no problems. I already had trackers blocked, but discovered I only had 3rd party cookies blocked in private mode; turned on blocking of 3rd party cookies entirely.

    Actually, your extension is working well enough that I can live with the status quo. These tabs don't snooze often enough to be really annoying and they refresh very easily, usually just by rolling the cursor over another part of the page. Just seems like more work than it's worth to go through all these various add-ons and extensions to finally pinpoint the issue. That Rolling Stone site is one that I might visit twice in a year, and my everyday sites are behaving very well. So I'm going to call this good. Thank you very much once again. I'll continue to have an alert enabled for new posts on this forum, if anything new surfaces and the mystery is finally solved. Who knows? Maybe the Opera people will finally take an interest in debugging this new, unneeded and unwanted feature. Just seems like they might have taken a look to see if it actually worked after releasing it.

  • @gizmogadget thanks, I did try the extension and it helps. It doesn't completely cure the problem, as I've had a couple of instances where tabs were snoozed regardless (I don't leave a computer or Opera running overnight)..
    Like you, I also run UBlock Origin, have 'do not track' enabled, third party cookies disabled (and have been working with computers since the 1980s!).
    It's a shame Opera can't make the 'disable' setting work as it would save us a lot of time, effort and missed messages.

  • @wickedaunt It's difficult trying to replicate the problems other people are having with tabs snoozing, did you read through the earlier posts where I mentioned "the extension marks new tabs as not to be snoozed, it won't work on tabs that were already open"?

    The PC tower I use has 16GB of ram installed, so I may be not getting any tabs that have to be snoozed because of low memory. I have an old laptop that only has 2GB of ram, I am going do some tests on there to see what happens, plus I can leave it going for longer as I am not using it. Will report back.

  • Well I did some tests... on the laptop I updated opera and installed the extension. Then opened 6 various tabs including Rollingstone, Amazon, Ebay, BBC News, I then left it going for just under 4 hours. On clicking each tab none were frozen.

    OK I thought, maybe it hadn't run low enough on memory to do anything, so I opened a video converting program, windows explorer, plus another 6 tabs including YouTube, then left it for 30 mins.
    Now when I clicked on the tabs they weren't frozen, but it sometimes took 2 ~ 3 seconds to redraw the tab. If I clicked along the row of tabs they would load up, and you could go back a few tabs ok but if you went right back to the first one it had to redraw again.

    I think this shows that it is very dependant on what hardware you have - ram, processor, graphics card memory & how many tabs you are clicking between as to whether you notice this happening.

  • After I upgraded from 74.0.3911.75 to 74.0.3911.160 for Windows x64 I had a couple of problems, and doing a clean installation of 74.0.3911.160 cured those. There is one problem, however, which I noted in ...75, and which is still present in ...160. It is impossible to permanently disable tab snoozing. Turning off the setting "Snooze inactive tabs to save memory" does not work - tabs are still snoozed.

  • We are obviously not going to get any satisfaction in this matter. It appears that the developers of Opera pay no attention to user complaints. For years I have used Opera for a number of specific purposes, but if a setting to disable an unwanted function does not work through a succession of revisions and after multiple user complaints I do not have to put up with software that does not work correctly. There are other browsers. Goodbye, Opera.

  • @dalehcook Yeah, I'm about ready to bail also. After saying a few days ago that the frequency was minimal enough that I could live with it, it's started to get considerably worse. My Gmail page now snoozes after about ten minutes of inattention, and I know from experience, i.e., an overnight account freeze, that Google takes a dim view of excessive sign-in/refresh activity. It really does mystify me why the Opera people can't - or won't - make this very simple fix.

  • I don't know if anyone did give up on Opera, I am sticking with it, the pros outweigh the cons.
    I was looking through the opera://flags/ to see if there were any other tab settings in there that were causing problems, I came across this setting: 'Calculate window occlusion on Windows'
    I googled it to find out some more info, there are a lot of stories on the issues this caused, here is one link:
    https://www.bleepingcomputer.com/news/software/google-fixes-white-screen-problem-in-chrome-admins-furious/
    In Opera 74.0.3911.218 it is enabled by default.